Slow startup or freezes after a factory reset or system update on my HUAWEI tablet/phone

Applicable products: Tablet,Smartphone
Applicable products:
zoom in pic
Slow startup or freezes after a factory reset or system update on my HUAWEI tablet/phone

Problem:

The device takes a long time to power on, or freezes when the user opens apps, after a factory reset or system update.

Cause:

  1. When the phone/tablet is powered on after a factory reset or system update, the system optimizes the apps, which may increase the time required for startup.
  2. After the phone/tablet is powered on, the system optimization process continues, which consumes much memory, and may cause freezing or lagging during app use.

Solution:

  1. Please wait for the system optimization process to complete. The more apps you have, the longer it will take to power on your phone/tablet.
  2. After an update, charge your device for 4 hours or more (it is recommended that you charge your phone overnight) with the screen off, then restart your device.
  3. If the issue persists, please contact the Huawei customer service hotline for assistance. We will do our best to address your needs.
Helpful or not?
Thanks for your feedback.

share

Share