Unable to enable navigation in Petal Maps on a watch or there is no navigation information

Applicable products: HUAWEI Watch
Applicable system: Unrelated to OS version
Applicable products:
Applicable system:
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Unable to enable navigation in Petal Maps on a watch or there is no navigation information

Problem:

After the user opens Petal Maps on their watch, the navigation function cannot be enabled or there is no navigation information displayed on the screen, as shown in the following figure.

Cause:

  1. The navigation function has not been enabled in Petal Maps on your phone.
  2. During navigation, if your phone has a poor network connection, has no network connection at all, or exits the navigation, your watch will not be able to display the navigation information.

Solution:

  1. Enable navigation in Petal Maps on your phone. Then open Petal Maps on your watch to start collaborative navigation.
  2. Ensure that the network signal is strong. Then enable navigation in Petal Maps on your phone again and open Petal Maps on your watch to start collaborative navigation.

For more usage instructions, please refer to:

1. Use Petal Maps on non-Huawei devices

2. Countries/regions where Petal Maps is available

3. Download Petal Maps

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