The screen flickers or a black screen is intermittently displayed after the monitor is connected to a host
The screen flickers or a black screen is intermittently displayed after the monitor is connected to a host |
Problem
The screen flickers or a black screen is intermittently displayed after the monitor is connected to a host.
Cause
There is a compatibility issue.
Solution
When the screen flickers after your monitor is connected to a host, perform the following operations:
1. If you are using an HDMI cable, check whether the cable is loose and whether the cable is an HDMI 2.0 cable purchased from an official channel.
2. If you are using the DP or USB-C port, check whether the port is securely connected and whether you are using the DP to MiniDP cable or the USB-C to USB-C cable delivered with the product.
3. Check with the graphics card vendor whether the graphics card supports the 3840 x 2560 resolution.
4. If a spare monitor is available, connect the monitor to the host, go to Device Manager > Display adapters, double-click a graphics card, and go to Driver > Update Driver. Alternatively, visit the corresponding graphics card vendor's website and download and install the latest driver.
5. Check for updates to Windows operating system. If a new version is available, update the system to the latest version.
6. If the issue persists, the graphics card may not be able to stably output the 3840 x 2560 resolution you are advised to reduce it to 3600 x 2400 or lower.
Note: If the issue persists, refer to FAQ en-gb15823261 and send all related information to R&D personnel.