The Wi-Fi icon on my computer is displayed as a small earth icon and my computer is unable to connect to a hotspot |
Problem
The Wi-Fi icon on the computer is displayed as a small earth icon and the computer is unable to connect to a hotspot.
Cause
- The Wi-Fi driver is incorrectly configured.
- Error code 10 is displayed in the network adapter, indicating that the Wi-Fi module hardware is faulty.
- The error code 56 is displayed in the network adapter because the registry is incorrect due to the installation of the virtual machine (VM) or other software. As a result, the driver cannot be identified.
- The system fails to identify the Wi-Fi driver because the driver is installed without a Huawei digital signature.
Solution
Check whether there is an error code displayed in the network adapter and make a note of what the error code is.
Right-click the Windows icon , go to Device Manager > Network adapters, check whether the Wi-Fi driver Intel(R) Dual Band Wireless - is displayed, then check if there is an error code displayed and make a note of what the error code is.
To do this, go to Device Manager > Network adapters and double-click Intel(R) Dual Band Wireless -.
Note: The Wi-Fi driver of the AMD-based computer is Realtek 8822CE Wireless LAN 802.11ac PCI-E NIC.
- If the computer is working properly, unplug the charger from the computer and press and hold the Power button for 15 seconds to power off the computer. Restart the computer and check whether the issue is resolved. If not, search for cmd in the search box on the taskbar and run the netsh winsock reset command to reset the network. To do this, perform the following:
Search for cmd in the search box on the taskbar, select Run as administrator to run cmd.exe, and run the netsh winsock reset command. Restart your computer, disable and enable Wi-Fi, and check whether this issue has been resolved.
Alternatively, go to Settings and select Network & Internet. Under Change your network settings, select Network reset, and then select Reset now. Click Yes. A message will then be displayed, indicating that Windows will close in 5 minutes. After that, the computer will automatically restart and the network will be reset.
If this issue persists, back up your data, press and hold or press consecutively F10 during startup to restore the computer to its factory settings.
- If the error code is 10, perform the following steps:
Restart your computer and disable and enable the Wi-Fi driver by performing the following: Right-click the Windows icon, go to Device Manager > Network adapters, right-click Intel(R) Dual Band Wireless -, click Disable device, right-click Intel(R) Dual Band Wireless - again, then click Enable device.
Note: The network adapter driver of the HUAWEI MateBook E 2019 is Qualcomm (R) wi-fi B/G/N/AC(2X2)SVc, and the Wi-Fi driver of the AMD-based computer is Realtek 8822CE Wireless LAN 802.11ac PCI-E NIC.
If the issue persists, unplug the charger from the computer and press and hold the Power button for 15 seconds to restart the computer. Disable and then enable the Wi-Fi again. If the issue still cannot be resolved, back up important data, then press and hold F10 to restore your computer to its factory settings. If the red cross icon is still displayed after the system is reset, bring your device and proof of purchase to an authorised Huawei Customer Service Centre for assistance.
- If the error code is 56, it may be because the computer cannot identify the driver due to the registry list being modified after the installation of VM and other software. Perform the following to use CCleaner to clear the registry list.
In Software Manager, search for CCleaner. After CCleaner is installed, select Registry > Scan for Issues > Fix All Selected Issues, and restart the computer.
If the issue persists, back up your data, and use F10 to restore your computer to its factory settings.
- If you cannot find Intel(R) Dual Band Wireless - displayed in Network Adapters or the error code is 52, it may be because you have installed unauthorised drivers on your computer. If the error code is 43, it may be because the network adapter has not been identified. You can uninstall the driver and install an authorised driver with a Huawei digital signature.
Download the Wi-Fi driver installation package from the official website to your computer. Then uninstall the current driver first, and then reinstall the new driver. To do this, perform the following:
(1) Uninstall the current driver. If no drivers have been installed, skip this step.
Open Device Manager, click Network adapters, right-click Inter(R) Wireless-AC 9560, click Uninstall device, select Delete the driver software for this device, click Uninstall, then restart your computer.
(2) After the uninstallation is complete, use the downloaded installation package to install the driver.
Restart your computer, connect your computer to the network (either wired or wireless), open PC Manager, click Manage drivers and then Check, select Wi-Fi driver, and click Update. After the update, restart your computer.
If you do not have a wired network, try sharing the network using a phone through a USB cable. For Android phones, go to Settings > Personal hotspot > USB tethering.