Unable to install the Cloud PC client
Applicable products: PC,Desktop
Applicable products:
These are your search results, please select one
No results found, please select again
zoom in pic
Unable to install the Cloud PC client

Scenario 1:

The Cloud PC client is unable to be installed, and a message is displayed, indicating that Microsoft.NET Framework is required.

Cause:

The PC does not have the necessary installation and running programs. As a result, the Cloud PC client is unable to be installed. This issue is not caused by software faults.

Solution:

  1. Install the Microsoft.NET Framework as prompted.
  2. If the issue persists, it is recommended that you install Microsoft.NET Framework by visiting the following link or contact the PC customer service personnel.

    Link: https://www.microsoft.com/en-gb/download/details.aspx?id=42642

Scenario 2:

The Cloud PC client is unable to be installed, and a message is displayed, indicating that there is no response or there are other errors.

Solution:

  1. You can try again when there is a strong network signal with no network access limitation.
  2. Check the system version of your PC. By default, the 64-bit installation package is downloaded from the official Cloud website. If your PC is 32-bit, click the 32-bit installation package to download and install it.
  3. Check whether Windows is the latest version. The installation may fail when using Windows 7 due to the lack of related system components. This issue is caused by the PC operating system and is not related to the software. It is recommended that you update the operating system from Windows 7 to Windows 10.

Currently, only Windows 7 SP1 and Windows 10 1803 or later are supported. If your computer is unable to install the software due to system issues, it is recommended that you update your PC's operating system to Windows 10 1803 or later and try again.

Helpful or not?
Thanks for your feedback.