На экране отображается диалоговое окно, сообщающее об ошибке сети при использовании программы HUAWEI MobileApp Engine
На экране отображается диалоговое окно, сообщающее об ошибке сети при использовании программы HUAWEI MobileApp Engine |
Проблема
Когда пользователь использует программу HUAWEI MobileApp Engine для запуска мобильного приложения, на экране отображается диалоговое окно, сообщающее об ошибке сети.
Причина
- Проблема связана с работой сети на вашем компьютере.
- Сеть, к которой подключен компьютер, запрещает запуск программы HUAWEI MobileApp Engine.
- Приложение в сервисе HUAWEI MobileApp Engine не может получить доступ к Интернету.
Решение
Решение 1. Если проблема связана с работой сети на вашем компьютере.
Для устранения ошибки см. https://consumer.huawei.com/en/support/content/ru-ru00692618/.
Решение 2. Если сеть, к которой подключен компьютер, запрещает запуск программы HUAWEI MobileApp Engine.
Для решения проблемы выполните следующие действия.
1. Проверьте, является ли текущая сеть школьной или корпоративной. Если да, то подключитесь к другой сети (например, к мобильной точке доступа) и повторите попытку.
2. Проверьте, установлено ли подключение к прокси-серверу или VPN. Если да, отключите прокси-сервер или VPN.
Для этого выполните следующие действия:
На компьютере перейдите в раздел Параметры > Сеть и Интернет.
2. Выберите опцию Прокси.
Убедитесь, что выключены функции Автоматическое определение параметров и Использовать прокси-сервер.
3. Проверьте, подключен ли компьютер только к сети протокола IPv6.
Для этого выполните следующие действия:
Откройте браузер и в адресной строке введите test-ipv6.com. Если адрес можно открыть и результат теста показывает, что компьютер подключен к сети IPv6, но не подключен к сети IPv4, это означает, что компьютер подключен только к сети IPv6. Проверьте, подключен ли компьютер и роутер к сети IPv4.
Подключите компьютер к сети IPv4, выполнив следующие действия:
На компьютере перейдите в раздел Параметры > Сеть и Интернет.
Выберите Дополнительные параметры сети, чтобы изменить сетевые адаптеры.
Правой кнопкой мыши нажмите на текущий сетевой адаптер и в открывшемся меню выберите опцию Свойства.
На открывшемся экране Свойства WLAN проверьте, выбран ли протокол IPv4 и действительна ли конфигурация.
Если компьютер уже подключен к сети IPv4, проверьте настройки роутера. Для получения более подробной информации о том, как проверить, подключен ли роутер к сети IPv4, обратитесь к поставщику роутера. Он поможет проверить настройки параметров и убедиться, что роутер корректно подключен к сети IPv4.
4. Если проблема сохраняется, выключите и снова включите программу HUAWEI MobileApp Engine или перезагрузите компьютер и повторите попытку.
Для завершения задачи в программе HUAWEI MobileApp Engine выполните следующие действия:
Откройте Диспетчер задач, выберите программу HUAWEI MobileApp Engine и нажмите Завершить задачу, как показано на изображении ниже.
Затем нажмите на программу HUAWEI MobileApp Engine, чтобы перезапустить ее.
5. Если проблема не решена, сделайте резервную копию данных и обратитесь в авторизованный сервисный центр Huawei.
Решение 3. Если приложение в программе HUAWEI Mobile App Engine не может получить доступ к Интернету.
1. Переустановите мобильное приложение и повторите попытку. Для этого выполните следующие действия:
Способ 1. Перейдите в Настройки > Приложения и возможности, выберите приложение, которое нужно удалить, и выберите Удалить.
Способ 2. Перейдите в раздел Я в HUAWEI AppGallery, выберите приложение, которое нужно удалить, и выберите Удалить.
2. Если проблема не решена, обратитесь в службу поддержки клиентов Huawei и сообщите название приложения. Huawei попросит разработчиков приложения решить эту проблему.