Unable to update satellite information on my HUAWEI watch
| Unable to update satellite information on my HUAWEI watch |
Problem
When the user goes to Settings > Workout settings > Location Services > Satellite updates > Update on their watch, a prompt Update failed or Update timed out is displayed.

Cause
- Your watch is disconnected from your phone via Bluetooth when updating satellite information.
- The Huawei Health app is cleared from the phone background, and the watch is not connected to the app.
- Your watch is connected to your phone, but your phone is not connected to the Internet.
Solution
- Make sure that your phone is connected to the Internet and your watch is properly connected to the Huawei Health app. You can check the watch connection status by going to Huawei Health > Devices.
- Make sure that your watch is connected to your phone via Bluetooth during satellite information updates. Otherwise, the update will be interrupted.
- If you are using a HUAWEI WATCH 4/5 Series/HUAWEI WATCH Ultimate 2 device, in addition to connecting the device to Huawei Health, you will also need to connect your watch to a Wi-Fi network, or activate the eSIM service and use mobile data, to update satellite information.
What is satellite information? Why do you need to keep satellite information on your watch up to date?
Satellite information contains the information used for GPS positioning, such as satellite orbit information and the satellite status. With updated satellite information, your watch can more accurately locate your position and map your workout routes. However, satellite information is dynamically updated. If it is not updated for a period of time, the positioning speed and accuracy of the device will be affected. It is recommended that you check satellite information at least every 1 to 2 days to ensure that it is updated.