An error message is displayed when I use WPS to edit a PDF file during Multi-Screen Collaboration indicating that I do not have permission

Applicable products: PC
Applicable products:
The following results have been found for you, please select
Unable to find the result, please select again
zoom in pic
An error message is displayed when I use WPS to edit a PDF file during Multi-Screen Collaboration indicating that I do not have permission

Problem

During Multi-Screen Collaboration between a computer and a phone, the user uses WPS to open and edit a PDF file located in Documents of the phone's drive. When the user saves the file, an error message is displayed indicating that the user does not have permission and the file fails to be saved.

Cause

The Documents directory is a virtual directory (category directory) and is different from directories in the internal storage. Currently, folders cannot be created in virtual directories (such as Documents, Images, and Videos). When editing and saving a PDF file, WPS will create a temporary file in the virtual directory where the file is located but the system will block WPS from doing so. As a result, the file cannot be saved.

Solution

1. Use another PDF editing software to edit PDF files, such as the browser that comes preinstalled with the Windows operating system.

2. Locate the PDF file you want to edit in the internal storage directory, access the category, and open and edit the file from there using WPS.

Helpful or not?
Thanks for your feedback.