The Reset all settings and Reset network settings buttons on my HUAWEI phone/tablet are unavailable
Applicable products:
Tablet,Smartphone
Applicable products:
Inquriy result as below, please select
Can't search result, please select again
| The Reset all settings and Reset network settings buttons on my HUAWEI phone/tablet are unavailable |
Problem:
After the user goes to on their device, they find that the Reset all settings and Reset network settings options cannot be selected, as shown in the following figure.

Cause:
- Your phone/tablet may be a customised device, for example, a phone/tablet purchased and distributed by a company or school.
- An installed third-party management and control app may have been activated.
Solution:
- If your phone/tablet is a customised device, contact the device distributor or supplier.
Customised device identification method:
- The startup logo and animation are customised. (Non-customised startup logo is "HarmonyOS".)
- Enterprise customisation is displayed on the Settings > About phone.
- If your phone/tablet is not a customised device, open Settings on your device, search for and access the Device administrators screen, and deactivate the activated non-preinstalled apps, as shown in the following figures.


If the issue persists
If the issue persists or you encounter any difficulties, please call the Huawei customer service hotline for assistance.
Thanks for your feedback.