The HUAWEI FamCare app displays a message indicating that the current network is unavailable or data fails to be obtained
Applicable products: HUAWEI WATCH KIDS 4 Pro
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The HUAWEI FamCare app displays a message indicating that the current network is unavailable or data fails to be obtained

Problem

  • The HUAWEI FamCare app on an Android/HarmonyOS phone displays No Internet connection. Please check your network settings., or the HUAWEI FamCare app on an iPhone displays Unable to load. Touch to retry., after the app is used to scan the QR code on the watch.
  • The HUAWEI FamCare app is stuck on the startup screen for a long time or a message is displayed indicating that information about the child linked with the account fails to be obtained and asks the user to try again.

Cause

The network of your phone or the HUAWEI FamCare app is abnormal.

Solution

  1. Check whether mobile data or Wi-Fi is enabled for your phone.
    • iPhone: Return to the home screen of your phone, swipe down to enter the control center, and turn on Cellular Data or WLAN.
    • Android/HarmonyOS phone: Swipe down from the top-right corner of the phone screen to enter the control center, and turn on Mobile data or WLAN.
  2. If your phone's network connection is normal, check whether the network permission is enabled for the HUAWEI FamCare app.
    • iPhone: Go to Settings > Cellular, touch the HUAWEI FamCare app from the app list, select WLAN & Cellular Data, and relink the app.
    • Android/HarmonyOS phone (using HarmonyOS 4.2 as an example): Go to Settings > Mobile network > Data usage > Network access, find the HUAWEI FamCare app, then select Mobile data and WLAN.
  3. Exit the HUAWEI FamCare app on your phone, relink the app, and try again.

If the issue persists or you encounter any difficulties, please contact the Huawei customer service hotline for assistance. We will do our best to address your needs.

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