Location error occurs in the HUAWEI Weather app
Location error occurs in the HUAWEI Weather app |
Problem
The following location errors occur in the HUAWEI Weather app:
- Unable to obtain the current location.
- The location is inaccurate. For example, city B is displayed when the user is actually in city A.
- The location update is performed slowly. For example, the location is updated to the actual city where the user is located half an hour after the user moved there.
Cause
- The user has not enabled the location permission for the Weather app.
- The phone's positioning is inaccurate.
- The positioning of the weather data service provider is inaccurate.
Solution
- Check whether the location permission is enabled for the Weather app.
To do so, go to Weather, touch Permissions, enable Location, and select Allow all the time or Allow only while in use.
, search for and access - Check and update HMS Core (Huawei Mobile Service) to the latest version.
Open AppGallery and search for HMS Core. If Open is displayed on the right, it indicates that the version is up-to-date. If Update is displayed, touch Update to update it to the version.
- Check whether the phone's positioning function is working properly.
Check whether the compass can be used properly: Open Compass and wait until the compass stops and displays the longitude and latitude.
If the compass can be used properly but the positioning function of the Weather app is abnormal, refer to My phone or tablet is unable to provide an accurate location or navigate to troubleshoot.
- If the issue persists
The following reply is only applicable to agents. For Internet issues, ask the user to call the hotline for consultation.
The agent should collect the following information and escalate the issue to HQ Technical Support.
- Device model.
- Phone's system version.
- Weather app version.
To check the version, open the Weather app and swipe down to the bottom.
- HMS Core (Huawei Mobile Service) version.
- Name of the current location, such as a province/state, city, or district.
- Screen recordings, screenshots, or logs of the fault.
- Screenshot of the longitude and latitude of the current location (check this by opening Compass and taking a screenshot after the compass stops).
- Screenshot of the Wi-Fi details page. To obtain the screenshot, perform the following:
(1) On your phone, go to Build number seven times consecutively to enter Developer mode.
and touch(2) Return to the first screen of Settings and go to .
(3) Return to the first screen of Settings, touch Wi-Fi, and take a screenshot of the Wi-Fi details screen, including the CONNECTED Wi-Fi networks and AVAILABLE Wi-Fi networks.