When I power on the computer, the screen has turned black, white, or blue, but I can move the cursor using the touchpad |
Problem
When the computer is powered on, the screen turns black, white, or blue. The user is able to move the cursor using their mouse or touchpad.
Cause
- Although unlikely, it is possible that Windows 10 has failed to display the desktop.
- There may be a compatibility issue with third-party software, resulting in the desktop display being suspended during startup.
- The Windows operating system may have a hardware fault which prevents it from starting normally.
Solution
1. Press and hold the Power button for more than 15 seconds to power off your computer, then press the Power button again to power it on. If the issue is resolved, perform the following steps to disable AppReadiness:
- Press Windows+R to open the Run window, and enter services.msc.
- Double-click AppReadiness. In the displayed Properties dialog box, set Startup type to Disabled.
2. If the fault persists after the restart, the system may not be working properly due to a third-party software compatibility issue. Press F8 during startup to enter safe mode and uninstall any recently-installed third-party software. If the problem persists, press F10 during startup to restore your computer to its factory settings.
Restoring the computer to its factory settings will clear all data on the C drive, including personal files in Desktop, Downloads, and Documents. Please back up any important data on the C drive before proceeding.
3. If you cannot restore the computer to its factory settings, or the issue persists after the restoration, back up all your important data and bring your device and proof of purchase to an authorised Huawei Customer Service Centre for assistance. If your device is newly-purchased, contact the dealer or seller.