[HUAWEI] When a third-party phone is connected to both the watch and the Bluetooth car kit/earphones, the call audio cannot be switched to the Bluetooth car kit/earphones
Applicable products:
HUAWEI WATCH FIT 4,HUAWEI WATCH GT 5 Pro,HUAWEI WATCH FIT 3,HUAWEI WATCH FIT 2,HUAWEI WATCH GT 3 SE,HUAWEI WATCH | ULTIMATE DESIGN,HUAWEI WATCH GT 3 Pro,HUAWEI WATCH 3 Pro,HONOR MagicWatch 2,HUAWEI WATCH GT Runner,HUAWEI WATCH GT Cyber,HUAWEI WATCH FIT 4 Pro,HUAWEI WATCH 4,HUAWEI WATCH GT 2 Pro,HUAWEI WATCH 5,HUAWEI WATCH GT 5,HUAWEI WATCH 3,HUAWEI WATCH 4 Pro,HUAWEI WATCH GT 2,HUAWEI WATCH D2,HUAWEI WATCH GT 4,HUAWEI WATCH 4 Pro Space Edition,HUAWEI WATCH GT 3
Applicable system:
Unrelated to OS version
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[HUAWEI] When a third-party phone is connected to both the watch and the Bluetooth car kit/earphones, the call audio cannot be switched to the Bluetooth car kit/earphones |
Problem
When a third-party phone, such as a Samsung or Xiaomi phone, is connected to both the watch and the Bluetooth car kit/earphones:
- When a call is initiated from or answered on the phone, the call audio is output from the phone receiver, rather than from the Bluetooth car kit/earphones.
- When a call is initiated from the Bluetooth car kit, the call audio is output from the phone receiver, rather than from the Bluetooth car kit.
Cause
This is caused by the third-party phone's audio policy. The phone sets up a call audio channel for the watch when they're connected. If a call is not initiated by the watch, the call audio will not output from the watch, but directly switch back to the phone receiver.
Solution
Resolve the issue by the following according to the watch and phone models:
- For HUAWEI WATCH GT 3 Series, HUAWEI WATCH GT Runner, and HUAWEI WATCH GT 3 Pro, guide the user to update the Huawei Health app and the watch to the following versions, in which the issue has been resolved:
- Huawei Health app: 12.1.6.320 or later
- HUAWEI WATCH GT 3 Series: 2.1.0.377(C00M08) or later
- HUAWEI WATCH GT Runner: 2.1.0.377(C00M08) or later
- HUAWEI WATCH GT 3 Pro: 2.1.0.389 or later
- HUAWEI WATCH FIT 2: 2.1.0.158 or later
- HUAWEI WATCH GT 2: 11.2.16.10 or later
- HUAWEI WATCH GT 2 Pro: (Reply) This issue will be resolved in a later version of the watch, which is scheduled for release in late January. Please stay tuned for the release date, and update the watch at your earliest convenience.
- If the watch is paired with a Xiaomi phone, update the phone to MIUI 13.0.6 or later.
- If the issue persists or the user is using other watch models, guide the user to switch the call to the Bluetooth car kit/earphones in any of the following methods:
- When a call has been set up, switch the call to the Bluetooth car kit/earphones on the phone.
- When there is an incoming call, wait for 3–5 seconds, and then answer the call using the Bluetooth car kit/earphones.
- Disconnect your watch from your phone. In this case, when you make a call using the Bluetooth car kit/earphones, the audio will come from the Bluetooth car kit/earphones.
- On the Bluetooth screen of your phone, disconnect your Bluetooth car kit, and reconnect it again.
- If the user does not accept the preceding solutions, guide the user to contact the customer service of the third-party phone.
Thanks for your feedback.