[HUAWEI] My wearable device is connected to my iPhone via the system Bluetooth, but fails to link with the HUAWEI Health app
Applicable products: HUAWEI TalkBand B6,HUAWEI WATCH FIT 3,HUAWEI WATCH FIT 2,HUAWEI TalkBand B3 Lite,HUAWEI WATCH GT 3 SE,HUAWEI WATCH | ULTIMATE DESIGN,HUAWEI WATCH GT 3 Pro,HUAWEI WATCH 3 Pro,HUAWEI WATCH Ultimate,HUAWEI Watch,HONOR MagicWatch 2,HUAWEI WATCH GT Runner,HONOR Watch GS Pro,HUAWEI WATCH GT Cyber,HUAWEI Talkband B5,HUAWEI WATCH 4,HUAWEI WATCH GT 2 Pro,HUAWEI WATCH 3,HUAWEI WATCH 4 Pro,HUAWEI WATCH GT 2,HUAWEI WATCH GT 4,HUAWEI WATCH GT 3
Applicable system: Unrelated to OS version
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[HUAWEI] My wearable device is connected to my iPhone via the system Bluetooth, but fails to link with the HUAWEI Health app

After you touch Add or Scan in the HUAWEI Health app, a message displays indicating that you need to enable Bluetooth and grant corresponding permissions for accessing the app's fitness data. On your phone, go to Settings > Privacy & Security > Bluetooth, and toggle on the switch for HUAWEI Health.

Problem

The HUAWEI Health app still reminds the user to pair their wearable device (which supports calling) with their iPhone via Bluetooth even though a Bluetooth connection has already been established.

Cause

Due to the way that Bluetooth works on iPhones, the message will appear after you go to Settings > Bluetooth, touch next to your wearable device, touch Name and change the Bluetooth name, and open the HUAWEI Health app to initiate a connection.

Solution

Find your paired wearable device in the Bluetooth list on your phone, touch next to the wearable device, and then Name, touch the delete icon X next to the text box to view its original name, and save the name. Then pair your devices again in the HUAWEI Health app.

If the issue persists or you encounter any difficulties, please call the Huawei customer service hotline for assistance.

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