A "Monitor connection may be restricted" notification appears when I connect my HUAWEI MateBook E Go to a docking station for projection
Applicable products:
The following results have been found for you, please select
Unable to find the result, please select again
A "Monitor connection may be restricted" notification appears when I connect my HUAWEI MateBook E Go to a docking station for projection |
Problem
After a user connects their HUAWEI MateBook E Go to a docking station for projection, the projection function is normal, and the external display works properly, but a message appears in the lower right corner of the screen, indicating that the monitor connection may be restricted.
Cause
Both USB-C ports on the computer support the DisplayPort function. This issue is related to the reporting process of certain docking stations. The system considers that the connection fails because the reporting is slow, even though the connection and projection are successful. However, the notification does not appear again after the projection is successful.
Solution
- Click the arrow icon in the upper right corner of the notification window to close it. The notification will not pop up again and will not affect your normal use.
- You can also block such notifications by going to Connection notifications. and turning off
- If the issue persists, back up your data and take your device and proof of purchase to an authorized Huawei Customer Service Center for assistance. (Tip: Feel free to call the Huawei consumer service hotline for assistance before going to a Huawei Customer Service Center.) We will do our best to address your needs.
Thanks for your feedback.