Why does an app downloaded from HUAWEI AppGallery prompt me that a new version is available for update when I open it?
Why does an app downloaded from HUAWEI AppGallery prompt me that a new version is available for update when I open it? |
Problem
When the user opens an app downloaded from HUAWEI AppGallery, the app prompts them that a new version is available for update, but there is not a message displayed in indicating that a new version is available.
Cause
- The app developers may not have submitted the new version in HUAWEI AppGallery, or HUAWEI AppGallery may have been reviewing the new version submitted by the developers to ensure that it is secure, in compliance with regulations, and can be used normally.
- The app developers may have been conducting a small-scale gray release test where the new version is only pushed to a specific number of users.
Solution
1. Wait for the app developers to submit the new version in HUAWEI AppGallery or for HUAWEI AppGallery to complete the approval process. After it is approved, HUAWEI AppGallery will display an update reminder. You can also perform the update in the app if needed.
2. Check on the official website of the app to see if the new version has been officially released. If you want to participate in the gray release test, contact the customer service of the app.
If you open an app and the app prompts you that a new version is available but you cannot perform the update or the update fails, contact Huawei customer service in your region and provide the name and latest version number of the app for assistance. If a new version can be found, we will contact the app developers and ask them to release the latest version as soon as possible. You can update the app in HUAWEI AppGallery once it is released.