The HUAWEI PC screen flickers or jitters, or displays wrong content or flickering lines
Applicable products:
PC,Desktop
Applicable system:
Windows 10, Windows 11
Applicable products:
Applicable system:
The HUAWEI PC screen flickers or jitters, or displays wrong content or flickering lines |
Problem
After the PC is powered on and the system is started, the screen flickers or jitters, or displays wrong content or flickering lines.
Cause
- The Panel Self Refresh (PSR) feature is abnormal.
- This is a compatibility issue with third-party apps.
- The graphics card driver is abnormal.
Solution
- Press and hold the Power button for 10 seconds to perform a forced shutdown, and then restart the PC.
- Perform the following steps to disable Panel Self Refresh.
- Enter Intel or Graphics Command Center in the search box on the taskbar.
- Open Intel Graphics Command Center, go to , and disable Panel Self Refresh.
System is displayed when the window is maximized. Otherwise, only
is displayed.
- After the settings are complete, restart the PC and check the screen.
- Open Huawei PC Manager and go to to update the graphics card driver to the latest version.
- If the issue persists, uninstall and reinstall the graphics card driver. The following uses HUAWEI MateBook 14 AMD 2020 as an example to describe how to uninstall the driver: Enter Device Manager in the search box on the taskbar and open it. Find Display adapters to expand it, right-click Uninstall AMD Radeon Graphics, and select Uninstall device. After the uninstallation is complete, power off and restart the device. For details, see Updating/Installing a driver on a HUAWEI PC.
The integrated graphics card driver varies depending on the processor.
- Intel processor: Intel(R) UHD Graphics 620 or Intel(R) Iris(R) Xe Graphics.
- AMD processor: AMD Radeon(TM) Graphics.
- Skip this step for HUAWEI MateBook E Go and HUAWEI MateBook E 2019.
- Check the third-party apps installed on your PC (apps not downloaded from software official websites or downloaded before and after the issue occurs, such as antivirus, manager, or cracked apps). If any, open Control Panel, access the Uninstall or change a program page, to uninstall the target program.
1. Refer to <Enabling or disabling Safe mode on my computer>to check if the screen flickering issue still persist in safe mode.
2. Use an external display to check if the screen flickering issue still persist.
If the issue still persist in safe mode but does not persist on the external display screen, remind users the risk of data loss and then guide them to offline service centers.
Thanks for your feedback.