The screen flickers after the computer system starts up

Applicable products: PC,Desktop
Applicable system: Windows 10, Windows 11
Applicable products:
Applicable system:
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The screen flickers after the computer system starts up

Problem

After the computer is powered on and enters the system, the screen flickers, jitters, is misplaced, or has thin lines.

Cause

  • The power saving feature of the screen self-refresh (PSR) is abnormal.
  • The third-party software is incompatible.
  • The video card driver is abnormal.

Solution

  1. Press and hold the power button for 10 seconds to forcibly power off the computer and then power it on again.
  2. To disable panel self-refresh, perform the following steps:
    1. Enter in the taskbar search box and enter the Intel or graphics control center, as shown in the following figure:

    2. Search for and open the Intel Graphics Control Center, click System > Power, and disable Panel Self-Refresh.

      The system displays text in the maximized window and icons in the window mode.

    3. After the settings are complete, restart the computer and observe the usage.
  3. Open Huawei PC Manager, and go to Optimization > Drivers. (For certain versions of Huawei PC Manager, you can find and click Drivers on the left.)

  4. Press Win+X and then press the M key on the keyboard, or press Win+X and select Device Manager from the list that is displayed in the lower left corner to open it.In the displayed Uninstall Device dialog box, select the check box Delete the driver software for this device. and click Uninstall.Then refer to the knowledge《Install a driver on a HUAWEI computer》 to reinstall the video card driver.

    The integrated graphics card driver varies depending on the processor.

    • Intel Processor: Intel (R) UHD Graphics 620 or Intel (R) Iris (R) Xe Graphics.
    • AMD Processor: AMD Radeon (TM) Graphics.
    • For the HUAWEI MateBook E Go/HUAWEI MateBook E 2019, skip this step.

Still unresolved?

If the issue persists, back up your data and press F10 to restore your computer to its factory settings. If the issue persists, take your device and proof of purchase to an authorized Huawei Customer Service Center for assistance. We look forward to hearing from you.

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