Unable to find the Cycle Calendar card in the Huawei Health app |
Problem:
Users can't find the Cycle Calendar card in the Huawei Health app.
Cause:
The Cycle Calendar card will be only displayed on the Health screen of the Huawei Health app when the user's gender is set to female and the age is between 18 and 55 in Profile.
Solution:
- Go to Huawei Health > Me > Profile, reset Gender and Date of birth, and try again.
- If the gender is set to Female but the age is not between 18 and 55, or the gender is set to Male or Rather not say, you can return to the Health screen, touch Edit, find the Available section, and touch the + icon in the upper right corner of the Cycle Calendar card, so that it's added to the Display on Health screen section.
If you are using an HONOR phone and don't find the Cycle Calendar card, you'll need to install HMS Core, log out of the Huawei Health app, and log in again.
The Cycle Calendar feature is currently unavailable in Australia, New Zealand, Dominican Republic, Bahrain, Republic of the Congo, Democratic Republic of the Congo, Djibouti, Tunisia, Réunion, Sao Tome and Principe, and Burundi.
If none of the above resolved the problem, call the Huawei customer service hotline for further assistance.