Black borders appear or the screen cannot be displayed in full screen when my computer is connected to an external monitor
Applicable products:
PC,Monitor,Desktop
Applicable system:
Unrelated to OS version
Applicable products:
Applicable system:
Black borders appear or the screen cannot be displayed in full screen when my computer is connected to an external monitor |
Problem
- When a HUAWEI computer or a computer of other brands is connected to a HUAWEI monitor in wired or wireless mode, black borders appear on the monitor or the screen cannot be displayed in full screen.
- When a HUAWEI computer is connected to a monitor of other brands in wired or wireless mode, black borders appear on the monitor or the screen cannot be displayed in full screen.
This issue usually occurs in screen projection in Duplicate mode. Display in Extend mode is normal.
Cause
- It is a normal occurrence that black borders appear during screen projection.
- The cable or docking station that connects the computer to the monitor is faulty.
- The projection mode of the monitor is incorrect.
- The aspect ratio of the computer resolution is different from that of the external monitor. For example, the default resolution of the monitor is 1920 × 1080 (screen aspect ratio: 16:9), but the default resolution of the computer is 3000 × 2000 or 2160 × 1440 (screen aspect ratio: 3:2). Therefore, in Duplicate mode, the computer outputs images at its own resolution, resulting in black borders on the monitor.
- Full screen mode is not the default zoom mode selected for the monitor. Proportional zoom mode or original picture mode is usually the default setting.
Solution
- For HUAWEI monitors, black borders between 4 mm and 7 mm do not indicate a fault. For non-HUAWEI monitors, please refer to the information released by the third-party vendors.
- If you are using a docking station or adapter, check whether the monitor resolution has reached the optimal recommended value. It is recommended that you use the end-to-end direct connection mode (Type-C/HDMI/DP/VGA directly-connected cable) or use a docking station and adapter with better compatibility to ensure that the output resolution meets the default recommended requirements of the monitor.
- For Windows computers, it is recommended that you select Extend or Second screen only by pressing Win+P when projecting the computer screen to a monitor.
- Try adjusting the zoom mode using the graphics card model control panel. Adjust the zoom mode of the monitor to Zoom full screen (stretch) or to Full panel. The method for doing this varies depending on the graphics card model and control panel. You can select a method based on your graphics card.
The adjustment may affect image display and cause exceptions such as blurry or unclear images.
- For Intel chip platform models of the new version — Intel Graphics Command Center
- Open the Start menu and open Intel® Graphics Command Center. (For Windows 11, click the Windows icon and then click All apps to search.)
- Go to Display > General. The default external display is Display 2. Select Display 2, choose Stretched from the drop-down list box on the right of extended options, and restart the computer.
- For Intel chip platform models of the old version — Intel Graphics Control Panel
- Open the Start menu in the lower left corner of the computer and open Intel® Graphics Control Panel. (For Windows 11, click the Windows icon and then click All apps to search.)
- Go to Scale Full Screen, apply the settings, and restart the computer. , select the display to be adjusted, set Scaling to
- For AMD chip platform models — AMD Radeon Software or AMD Radeon Settings:
- Open the Start menu and open AMD Radeon Software. (For Windows 11, click the Windows icon and then click All apps to search.)
- On the Display page, go to , and restart the computer.
- For Intel chip platform models of the new version — Intel Graphics Command Center
- Adjust the resolution of the laptop to be the same as, or close to, the default resolution of the monitor.
- Right-click in the blank area on the desktop and choose Display settings from the shortcut menu. In the resolution drop-down list, select a resolution that is the same as or similar to the default resolution of the monitor.
- Windows 10: .
- Windows 11: .
- When the resolution of the computer is reduced, the content displayed on the screen (such as icons, fonts, and apps) may be blurred or stretched. If this happens, adjust the zoom ratio based on your preferences. In addition, adjust the zoom mode of the monitor to Zoom full screen (stretch) or to Full panel by referring to the preceding operations.
- Restart the computer for the settings to take effect.
- Right-click in the blank area on the desktop and choose Display settings from the shortcut menu. In the resolution drop-down list, select a resolution that is the same as or similar to the default resolution of the monitor.
If the issue remains unresolved, feel free to contact Huawei after-sales personnel for assistance.
Thanks for your feedback.