PC AppGallery cannot connect to the network or server
Applicable products:
PC,Desktop
Applicable system:
Windows 10, Windows 11
Applicable products:
Applicable system:
PC AppGallery cannot connect to the network or server |
Problem
The message "No Internet connection. Check your network settings." is displayed when PC AppGallery is started.
Cause
- The network is unstable or abnormal.
- A proxy server has been configured, and AppGallery cannot be accessed through the proxy network.
Solution
- Connect your PC to another network. For example, connect your PC to a shared Wi-Fi hotspot or to a wired or Wi-Fi network. If the issue is resolved, it indicates that the previous network connection is restricted or abnormal. In this case, reset your router and try again, or contact your network operator for confirmation.
- If AppGallery can't be accessed in some proxy networks, disable the proxy server by performing the following steps:
For Windows 10, go to the Start menu in the lower left corner, go to , and disable Use a proxy server.
For Windows 11, click the Wi-Fi icon in the lower right corner, go to Use a proxy server.
, and disable - Open the Start menu in the lower left corner, go to , right-click AppGallery in All apps, and choose Uninstall from the shortcut menu. In the PC Manager sidebar, download the PC AppGallery installation package and reinstall it.
- If the network still can't be connected after the above solution is tried, provide logs for further check.
To provide PC AppGallery logs, perform the following steps:
Go to C:\Users\User name\AppData\Roaming\appGallery\log, compress the log file directory, contact and send an email containing the attachment to Huawei customer service.
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