When I install an app on my HUAWEI computer, a prompt displays indicating that the app has been blocked or the app has been blocked by the SAC |
Problem
When the user is installing an app on their computer, a prompt displays indicating that the app may be insecure and has been blocked by the Smart App Control (SAC). For example, software like Kingdee displays a prompt, indicating that this app has been blocked to protect the computer.
Cause
SAC is introduced as of Windows 11 version 22H2 by Microsoft as a new feature designed to block apps that are malicious or untrusted, based on Windows code integrity and Microsoft's intelligent application services. If the app being installed contains some unsigned or malicious files, the SAC will block it.
Solution
Method 1:
Find the insecure app, contact its provider, and download the latest version of the signed app.
Method 2:
Press Win+I to open Settings, and go to
, and disable Smart App Control.Click here to open Windows Security.
Method 3:
If a certain software is required but its reliable software installation package can't be obtained, you need to disable SAC and use a third-party protection software to enhance system security. If you have any questions, contact Microsoft customer service for further consultation and assistance. You can also log in to the Microsoft official website, click Contact Microsoft at the bottom of the home page, and follow the onscreen instructions for assistance. Alternatively, you can contact the software provider for assistance. Thank you for your understanding and support.
- SAC enhances the protection against untrusted apps. For details, visit the Microsoft official website at What is Smart App Control?.
- Note that once the SAC is disabled, the software evaluation function will be unavailable. If you need to use the function, reinstall the latest version of the mirror system.
- If the Kingdee software keeps blocking app installation after the preceding solution is used, reply that "Huawei has reported this issue to Kingdee. Kingdee is already aware of this issue. You can call Kingdee service hotline and provide your software provider for assistance."