Cursor is permanently loading when I right-click on the computer desktop
Applicable products: HUAWEI MateBook X Pro(2019 intel i7/16g/1t/uhd620、2019 no os vervion intel i5/8g/512g/mx250、2019 no os vervion intel i7/8g/512g/mx250),HUAWEI MateBook 13( intel i7/8g/512g/mx250、no os vervion intel i7/8g/512g/ mx250、no os vervion intel i5/8g/512g/ mx250、 intel i5/8g/512g/mx250)
Applicable system: Windows 10, Windows 11
Applicable products:
Applicable system:
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Cursor is permanently loading when I right-click on the computer desktop

Problem

After the user right-clicks anywhere on the desktop, a loading circle is displayed. The user then cannot perform further operations.

Cause

This is because the NVIDIA graphics card driver (version 25.21.14.1634) that was updated using a third-party app is incompatible with the Windows system.

This applies only to computers with NVIDIA graphics cards.

To view the graphics card model and driver version information:

  1. Right-click My PC, click Properties, as shown in the following figure, and click Device Manager in the pop-up window.
  2. In Device Manager, double-click Display adapters to expand it, right-click the listed graphics card, and choose Properties from the shortcut menu to open it. If the computer has multiple graphics cards, view them one by one.

  3. Click Driver to view the graphics card model and the driver version. Check whether the version of your NVIDIA graphics card is 25.21.14.1634. If yes, modify the registry by performing the following steps. If the computer has multiple graphics cards, one of them is NVIDIA, and the driver version is 25.21.14.1634, perform the following steps.

Solution

To prevent risks caused by incorrect registry modification, back up the registry data in advance by referring to Backing up and restoring the registry data on a Windows computer.

  1. Enter regedit in the search box on the taskbar and click Registry Editor.

  2. Select HKEY_CLASSES_ROOT on the left pane of Registry Editor, and expand HKEY_CLASSES_ROOT > Directory > Background > shellex > ContextMenuHandlers > NvCplDesktopContext.
  3. Right-click NvCplDesktopContex and click Delete.

  4. Close Registry Editor. Right-click the taskbar, click Task Manager, and go to Details > explorer.exe > End task.

  5. Click File and then Run new task. In the dialog box next to Open:, enter explorer.exe, click OK, and restart Task Manager.

If the issue persists

If the issue persists, back up your data in advance, record your Office account, and use F10 to restore your computer to its factory settings. If the issue remains unresolved, take your device and proof of purchase to an authorized Huawei Customer Service Center for assistance. We will do our best to address your needs.

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