The altitude calculated by my watch is inaccurate |
Problem
The altitude displayed on the watch is inaccurate.
Cause
The watch calculates altitude based on the data collected by the barometer sensor. This data may not be accurate due to the change of the ambient temperature and air flow when you are taking different modes of transportation (such as vehicles, subways, airplanes, and high-speed railways). Therefore, it is recommended that you calibrate your device in an open outdoor area when you need a more accurate altitude reading.
Solution
1. Go to an open area, open the Barometer app, swipe up to access the Altitude screen, and touch Calibrate. You will see Calibrating… displayed. Try to stay in the same place for 2 to 3 minutes to give your device time to calibrate properly. The calibration will not be affected if the screen turns off or you use other apps.
2. If your GPS positioning is working accurately, you can also calibrate the altitude feature by starting an outdoor workout in an open area and exercising for more than 5 minutes.
1. Before calibration, make sure that the watch's satellite data has not expired.
2. If you see displayed to the right of Calibrate, the Altitude feature needs to be calibrated. Follow the steps above to calibrate the altitude feature before using it.
3. The in-cabin atmospheric pressure will fluctuate when you are flying in an airplane. It is not possible to obtain accurate altitude readings during a flight. Once you land, you will need to recalibrate the altitude feature.
4. When you power the watch off and then power it on again, the altitude value shown will be recalculated based on the altitude reading before the power-off and the difference in altitude after the power-on. Therefore, altitude readings may be inaccurate if you power the device off and on in different places. To resolve this, recalibrate the altitude in a timely manner.