目录
选择版本
    智慧搜索恢复已卸载应用,提示“恢复失败”、没有“恢复”按钮
    适用产品: 手机,平板
    适用版本: Magic UI, HarmonyOS 3.1, HarmonyOS 4.0, HarmonyOS 4.2, HarmonyOS 2.1, HarmonyOS 3.0, HarmonyOS 2.0, EMUI, HarmonyOS 2.0.1
    适用产品:
    适用版本:
    为您查询到以下结果,请选择
    无法查询到结果,请重新选择
    zoom in pic
    智慧搜索恢复已卸载应用,提示“恢复失败”、没有“恢复”按钮

    问题现象:

    智慧搜索搜索已卸载的应用时,没有“恢复”按钮,或点击恢复提示“恢复失败”。

    问题原因1

    当您开启了多用户,子用户下该应用版本号比目前主用户下该应用版本号高,导致恢复失败。

    解决方案1

    1. 卸载子用户中该应用

      您开启了多用户,子用户下应用版本号比目前主用户下应用版本高,导致恢复不了,需将子用户中该应用也卸载掉才可恢复成功,请在设置>用户和账户>多用户,进入子用户和访客,卸载应用。

    2. 卸载隐私空间中该应用

      上述方法无效请排查隐私空间,在设置 > 隐私(安全和隐私) > 隐私空间,卸载应用。

    3. 关闭隐私空间或子用户

      您开启了多用户,子用户下应用版本号比目前主用户下应用版本高,导致恢复不了,需将子用户中该应用也卸载掉才可恢复成功,请在设置>用户和账户>多用户,进入子用户和访客,卸载应用。

    问题原因2

    以下三种情况不支持通过智慧搜索恢复已卸载应用:

    1. 系统升级后,应用包名发生变化,导致恢复失败。
    2. 如您使用的是智慧搜索海外版本(搜索版本号以2开头)。
    3. 智慧搜索仅支持恢复已卸载的系统自带应用,不支持恢复第三方应用。

    解决方案2

    进入应用市场重新下载:

    1. 若搜索界面搜索不到已卸载的应用,请您前往应用市场重新下载。
    2. 如果您在应用市场中,搜索不到已经卸载的应用,请进入 “应用市场”,点击“安装管理”,找到已经卸载的应用,点击“安装”。

    仍然无法解决?

    如果仍未解决,建议您备份好数据,恢复出厂设置后即可恢复被卸载的应用。

    是否有帮助?
    谢谢您的鼓励!