目录
选择版本
    计算机无法正常登录OneDrive
    适用产品: 台式机,笔记本
    适用版本: Windows 10, Windows 11
    适用产品:
    适用版本:
    为您查询到以下结果,请选择
    无法查询到结果,请重新选择
    zoom in pic
    计算机无法正常登录OneDrive

    问题现象

    OneDrive无法正常登录:

    1. 登录OneDrive时一直转圈圈,或提示报错"登录时出现问题,请稍后重试"。

    2. 登录OneDrive的时候,提示错误代码0x8004def7(或0x8004de44)。

    问题原因

    1. 登录OneDrive需要连接到微软服务器,但是微软服务器不在国内,当网络不好或微软服务器不稳定时会出现连接不顺畅的情况。
    2. 提示0x8004def7错误,是因为如果超过 1 年未使用该微软帐户,或者超过 OneDrive 三个月存储时间限制,导致OneDrive 帐户被冻结。或系统中存的配置信息和微软云端一些配置信息不一致。

    解决方案

    针对现象一:

    1. 请参考《华为计算机如何管理防火墙》重置防火墙设置。

    2. 更改网络链接DNS地址,以便于快速访问微软服务器。具体操作步骤如下:
      1. 在任务栏左下角搜索框中输入控制面板

      2. 查看方式更改为"小图标",找到“网络和共享中心”。

      3. 点击更改适配器设置

      4. 右键点击当前已连接的网络,点击属性,在弹出的窗口中双击Internet 协议版本4,点击使用下面的DNS服务器地址,填入4.2.2.2,备选4.2.2.1,点击确定。

        DNS服务器地址修改后会导致国内网络访问速度较慢,操作完成后,将DNS网址更改为默认选项自动获得DNS服务器地址,IP地址获取也改回自动获得IP地址。

    3. 更换或重置网络。

      更换连接其他网络(如手机热点、USB共享网络或连接有线网络)或重置当前网络并还原Internet默认选项。

      通过 USB 有线共享网络:

      1. 使用 USB 数据线将手机(安卓或HarmonyOS)与电脑连接。
      2. 在手机上进入设置 > 移动网络 > 个人热点 > 更多共享设置,开启 USB 共享网络开关,共享移动网络或已连接的 WLAN 网络给电脑。
      1. 重置网络方法:在任务栏搜索框输入“cmd”,鼠标右键命令提示符,点击以管理员身份运行,命令提示符输入如下命令“netsh winsock reset” (该命令只是清理计算机内关于网络winsock目录重置为默认设置或清除状态,不会影响到您的电脑使用),然后重启计算机即可。如下图 :

      2. 还原Internet选项方法:在任务栏搜索框输入Internet选项,选择并打开后,点击高级>还原高级设置选项,点击确定完成后重启计算机。

    针对现象二:

    1. 点击解决此问题登录 OneDrive 网站,按照屏幕上的说明取消冻结

    OneDrive微软云盘使用与网络运营商或网络条件有强相关性,如无法登录请联系微软。

    1. 若无效,请参考《华为计算机如何注册微软帐户》重新注册新的微软帐户登录尝试。

    仍未解决?

    由于OneDrive为微软Windows系统预置应用,其服务支持由微软提供,为了精准定位并快速解决您的问题,建议您可联系微软客服400-820-3800(手机或固话)、或800-820-3800(固话)按语音提示获取更多的咨询与帮助。或者您也可以通过登录微软中国官网,点击网页最下方的联络 Microsoft,按网页提示进行在线咨询。感谢您的理解与支持,祝您生活愉快!

    是否有帮助?
    谢谢您的鼓励!