目录
选择版本

    手机端智慧生活App中,华为打印机详情界面复印和扫描按键置灰,无法使用

    适用产品: HUAWEI PixLab B5,HUAWEI PixLab V1,HUAWEI PixLab X1
    适用版本: 不涉及系统版本
    适用产品:
    适用版本:
    为您查询到以下结果,请选择
    无法查询到结果,请重新选择
    zoom in pic
    手机端智慧生活App中,华为打印机详情界面复印和扫描按键置灰,无法使用

    本知识适用于华为喷墨打印机和华为激光打印机,涉及到的具体操作以 HUAWEI PixLab X1 操作界面为例,其他华为打印机操作类似、操作界面可能有所不同,请以实际情况为准。

    问题现象

    手机智慧生活App中,打印机详情界面只有打印图标是可点击的,复印扫描图标置灰且点击无反应。

    问题原因

    手机和打印机之间的局域网通信中断,启用了云打印通道,此时,不支持复印、扫描功能。

    具体原因包括:

    1. 打印机的IP地址发生了变化,导致手机无法与打印机进行局域网通信。
    2. 打印机与电脑连接的不是同一个WLAN(即同一个局域网)。
    3. 打印机和手机连接的是相同的WLAN,但是网络信号不稳定,或者路由器设置了AP隔离功能。

    解决方案

    手机端复印扫描图标置灰问题的排查和处理思路如下:排查网络本身的问题(对应步骤123) > 排查路由器是否设置了AP隔离 > 重新为打印机配置网络> 为打印机设置固定IP

    1. 对于华为激光打印机:请首先确认打印机的有线网络和无线网络没有同时连接上(查看打印机背后网口是否插有网线,以及打印机操作面板点亮时“网络状态”键 是否白灯常亮),如果同时连接了需要先取消有线连接,将网线拔掉即可。
    2. 请点击手机屏幕左上角返回键,退出华为打印插件界面,再重新点击打印机卡片打开华为打印插件。
    1. 请长按打印机操作面板上“开始”键3 秒以上,听到“滴”声松开按键,开始键白色闪烁,打印机将自动打出信息页,请在无线网络信息部分查看打印机的网络标识MAC地址IPv4地址信息。

      请根据“网络标识”信息确认打印机是否与计算机连接到同一个WLAN网络中:
      • 如果不是,请执行步骤5重新给打印机配置网络,将打印机更换到与手机同一个WLAN网络,或者将手机更换回打印机所连接的WLAN网络,问题解决;然后执行步骤6为打印机设置固定IP,可以一定程度上避免再发生此类问题。
      • 如果打印机已经与手机连接到同一个WLAN网络,请确认WLAN网络信号质量是否良好。
        • 如果WLAN网络质量不稳定,请把打印机搬到离路由器比较近的地方,加强路由器信号质量,后续此问题即可得到改善。
        • 如果WLAN网络质量良好,请继续执行后续排查步骤。
    2. 请排查路由器是否开启AP隔离功能,如果开启,请按照如下操作指导关闭路由器的AP隔离功能,再等待约两分钟看手机智慧生活App的打印机详情界面复印和扫描按钮能否自动恢复为可用状态。

      如果能自动恢复,问题解决;如果不能自动恢复,则说明打印机的IP地址可能已经发生了变化,请继续执行步骤5重新给打印机配置网络。

      • 以华为路由器为例(其他品牌路由器详细操作请咨询各品牌路由器客服人员,新款HUAWEI路由器已取消AP隔离功能,此处以老款界面为例介绍):

        在浏览器地址栏中输入192.168.3.1登录路由器Web界面,进入设置 > WLAN > WLAN高级设置,找到AP隔离并选择关闭,点击应用

      • TP-LINK路由器关闭AP隔离方法(此处仅供参考,不同路由器登录方式或操作界面可能会有差异,具体请咨询各品牌路由器客服人员):

        在浏览器地址栏中输入192.168.1.1登陆路由器管理界面,点击应用管理,然后点击AP隔离下方的进入,在AP隔离界面选择,再点击下方保存即可。

    3. 如果步骤4执行后等待约2分钟,手机智慧生活App的打印机详情界面复印和扫描按钮仍然无法恢复为可用状态,请将打印机网络重置,删除华为智慧生活APP的打印机设备,然后重新为打印机配置网络,具体操作方法如下:
      1. 打印机开机状态下,长按打印机操作面板上的网络键 3 秒以上,直到打印机发出“滴”声以及网络键 白色闪烁,说明打印机网络设置已被重置。
         
        • 重置网络设置可能导致打印机IP地址,局域网等设置发生变化。
        • 如果之前有在华为打印客户端给打印机设置过固定IP(具体步骤请参考华为打印机如何固定 IP 地址),建议长按打印机面板上的取消键 10 秒以上将打印机恢复出厂设置(面板会先出现数字“88”表示开始重置打印机,待面板显示“01”,则表示已重置完成),然后将打印机断电重启,2分钟左右等待扫描仪复位完成之后再进行配网。
      2. 在智慧生活App删除华为打印机。打开华为智慧生活 App ,在首页中长按打印机设备,在弹出的界面中选择删除设备,按界面确认删除即可。

      3. 重新给打印机配置网络。
        1. 请确认手机已经连接到和打印机相同的目标WLAN网络,如果不相同,请切换手机所连接的WLAN。
        2. 请通过手机智慧生活App给打印机配网,具体操作请参考:
    4. 重新给打印机配置网络后,执行本步骤为打印机设置固定IP,可一定程度上避免后续再发生此类问题。具体操作方式有两种:
      • 方式一:在路由器侧设置IP地址和MAC绑定(推荐方案)
        进路由器设置界面将打印机的MAC地址和打印机的IP地址做一下绑定,可以做到此IP专门给打印机用,确保不会再分配给其他设备。不同品牌路由器设置方法不同,具体请咨询相应品牌技术支持,此处仅以华为路由器和TP-Link企业级路由器为例给出操作指导:
        • 华为路由器:

          请长按打印机操作面板上“开始”键3 秒以上,直到打印机发出滴的一声,打印系统信息页,在无线网络信息部分查看打印机的MAC地址和IPv4地址,在路由器上设置打印机IP和MAC地址绑定,路由器侧的具体操作可参考:修改华为路由器的 IP 地址和绑定静态 IP 地址

        • TP企业级路由器(仅供参考):
          1. 打开浏览器输入路由器的IP地址(常见为“192.168.1.1”,不同品牌路由器IP地址和操作界面可能会有差异,请以实际情况为准)并回车进入路由器后台登录界面,输入帐号密码并回车进入路由器后台管理界面。
          2. 如下图所示,请您依次点击基本设置>LAN设置>静态地址分配>新增,输入打印机的“IPv4地址”和“MAC地址”进行绑定即可(打印机IP地址和MAC地址的查询方法同华为路由器的相关步骤说明)。

      • 方式二:通过计算机在华为打印客户端设置固定IP

        在路由器侧设置IP地址和MAC绑定可以彻底解决打印机IP地址变化的问题,但是如果您不方便(例如,无法获取路由器的登录地址或登录密码)操作路由器,也可以暂时在计算机上的华为打印客户端设置固定IP恢复打印机的连接,但后续可能还会发生打印机IP地址变化导致华为打印客户端出现CLOUD图标的现象,此时还是需要在路由器侧设置IP地址和MAC绑定才可以彻底解决问题。

        在计算机上的华为打印客户端设置固定IP,具体操作请参考华为打印机如何固定 IP 地址

    仍未解决?

    若问题仍不能解决,请拨打华为客服服务热线950800进行咨询,我们将竭诚为您服务,祝您生活愉快!

    是否有帮助?
    谢谢您的鼓励!