日历日程无法同步至云空间、日历界面不显示日程/加载日程很慢
适用产品:
手机,平板
适用版本:
HarmonyOS 3.1, HarmonyOS 4.0, HarmonyOS 4.3, HarmonyOS 4.2, HarmonyOS 2.0
适用产品:
适用版本:
为您查询到以下结果,请选择
无法查询到结果,请重新选择
日历日程无法同步至云空间、日历界面不显示日程/加载日程很慢 |
问题现象:
用户无法同步日历至云空间,或打开日历app界面不显示日程/加载日程很慢。
问题原因:
日历项的日程个数达到3万条上限导致无法同步,查看路径:云空间>管理云存储空间,查看界面中日历项的日程个数,是否达到3万条上限。
解决方案:
方法1:(升级Harmony3.0可自动修复)
Harmony3.0增加了日历日程去重功能,如果设备支持升级Harmony3.0,优先升级Harmony3.0,升级完成后打开日历APP,将日历APP退出至后台运行,一般经过6h左右后可自行恢复。
方法2:(打开日历界面等待自动恢复)
详细操作步骤如下:
- 设置手机不自动灭屏或10分钟灭屏;(避免清理过程中灭屏导致中断)(不知道如何设置,[见附图1])
- 打开日历界面,进入日程视图(不知道如何进日程视图,[见附图2]);
- 静置在日程列表界面一段时间(保持不灭屏)(建议10-30分钟),等待自动清理冗余数据;
静置页面示意见:[见附图3]
- 静置一段时间后,再此重复步骤2、3,这一次进入日程视图时,应该能感觉到加载速度变快(数据已经被清理一部分了);
- 步骤4操作过程中,如果日程列表加载的较快,则点一下“查看xxx之前的日程”(操作示意图,[见附图4]),以防是因为2年前的日程过多冗余所致,需要加载才能执行去重;
- 重复数据不是特别多(5w以下)的情况下,一两次操作后应可修复问题;
Tips:少量用户本地堆积的日程过多,静置一段时间后会自动退出,达不到清理的效果,此时则不能在“日程”视图静置,应在“月”视图静置(操作方法同附图2)。或按方法3处理。
方法3:(针对方法2长时间静置无效,可按照如下方法操作,但可能会造成日程数据丢失)
注意:一部分数据会从云空间下载下来,但还可能存在一部分未上传至云空间的数据丢失,请您谨慎操作。
- 前往设置>应用和服务>应用管理,点击右上角菜单点击显示系统程序,搜索日历存储,点击日历存储>存储>删除数据。即可一次性清空本地所有日程数据。
- 清空本地日程数据后,前往云空间,打开日历云同步开关,等待同步完成(可能耗时10分钟)。
- 同步完成后,可按方法2静置在日历“日程”视图,等待10分钟左右(具体时长以实际情况为准)功能即可恢复正常。
附图1:
附图2:
附图3:
附图4:
如果以上方法仍未解决您的问题或者操作中遇到困难,请您联系华为热线950800详细咨询,我们将竭诚为您服务,祝您生活愉快!
谢谢您的鼓励!