使用系统盘瘦身的文件搬移功能时桌面文件显示不完整
适用产品:
台式机,笔记本
适用版本:
Windows 10, Windows 11
适用产品:
适用版本:
为您查询到以下结果,请选择
无法查询到结果,请重新选择
使用系统盘瘦身的文件搬移功能时桌面文件显示不完整 |
问题现象
完成文件搬移或恢复文件后,桌面文件显示不完整。
现象一:搬移或恢复文件后,部分桌面文件不显示(如下图),目标路径下桌面文件夹中有完整文件,原路径下有桌面文件夹。
现象二:搬移或恢复文件后,桌面仅显示回收站(如下图),目标路径下桌面文件夹中有完整文件,原路径下没有桌面文件夹。
问题原因
在文件搬移或恢复时,由于占用或权限等原因,可能会导致文件搬移或恢复完成,但是路径未修改成功,或注册表中的路径未更新成功。从而导致桌面路径未指向完整文件路径,造成桌面文件显示不完整。
解决方案
以下解决方案仅以Windows11操作系统为例:
针对现象一:
- 从系统盘转移非系统盘的操作称之为搬移操作;从非系统盘转移到系统盘称之为恢复操作。
- 以下解决方案以“系统盘C盘”和“参与搬移/恢复的非系统盘D盘”为例:
- 若文件从C盘搬移到D盘,C盘存放路径(通常为:C:\Users\[用户])称之为原路径,目标盘D盘存放路径(通常为:D:\HuaweiMoveData\Users\[用户])称之为目标路径。
- 反之,若文件从D盘恢复到C盘,则原路径为D盘存放路径(通常为:D:\HuaweiMoveData\Users\[用户]),目标路径为C盘存放路径(通常为:C:\Users\[用户])。
进入原路径下,右键点击桌面文件夹图标,手动更改路径。具体操作如下:
- 进入原路径下,右键点击桌面,选择属性。
- 选择位置菜单栏,点击还原默认值(适用实际文件路径为“系统盘”的情况)或手动输入实际文件路径。
- 实际文件路径:代表实际存储着完整桌面文件的路径,一般多为操作后的“[目标路径]\Desktop”,恢复操作前请找到并验证这个路径。验证方法如下:打开文件资源管理器
,找到并进入“[目标路径]\Desktop(或叫:桌面)”,确认Desktop(桌面)文件夹下有用户完整的桌面文件。
- 下图以错误路径“D:\HuaweiMoveData\Users\[用户]\Desktop” 改为实际文件路径“C:\Users\[用户]\Desktop”为例,具体以用户实际使用情况为准。
- 实际文件路径:代表实际存储着完整桌面文件的路径,一般多为操作后的“[目标路径]\Desktop”,恢复操作前请找到并验证这个路径。验证方法如下:打开文件资源管理器
- 手动还原成实际文件路径后,点击确定。
- 确认移动路径:在移动文件夹确认框点击是。
- 提示包含同名文件界面,选择跳过这些文件,路径即可更新完成。
针对现象二:
原路径下没有桌面文件夹,需要在注册表更改路径,具体操作如下:
- 在搜索栏中输入注册表编辑器,点击打开注册表编辑器。
为避免注册表修改错误产生相关风险,请参照Windows 计算机如何备份/恢复注册表数据提前备份注册表并谨慎操作。
- 找到“计算机\HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer”路径下Shell Folders和User Shell Folders文件夹下的Desktop项(如下图),双击Desktop项弹出修改弹窗。将数值数据修改为实际文件路径,点击确定,路径修改成功。
下图以错误路径“D:\HuaweiMoveData\Users\[用户]\Desktop” 改为实际文件路径“C:\Users\[用户]\Desktop”为例,具体以用户实际使用情况为准。
- 依次点击开始> 用户名 >注销后重新登录系统,注册表修改生效,桌面文件恢复。
仍未解决?
如果以上方法未解决您的问题,请您随时联系我们售后(华为消费者服务热线 950800),我们将竭诚为您服务,祝您生活愉快!
谢谢您的鼓励!