目录
选择版本

    计算机通过华为电脑管家升级OneKey驱动后,不断提示需要更新

    适用产品: HUAWEI MateStation X,台式机,笔记本
    适用版本: Windows 10, Windows 11
    适用产品:
    适用版本:
    为您查询到以下结果,请选择
    无法查询到结果,请重新选择
    zoom in pic
    计算机通过华为电脑管家升级OneKey驱动后,不断提示需要更新

    问题现象

    通过华为电脑管家升级OneKey驱动,重新启动计算机后,依旧显示OneKey驱动待更新

    问题原因

    1. 华为电脑管家读取注册表中OneKey驱动的版本号,并和OTA推送的OneKey驱动版本号比较。当OTA推送的驱动版本号新时,提示驱动待更新。
    2. OneKey驱动OTA包下载成功,管家会认为更新成功。但实际上,OTA包下载成功后,会检查环境条件,当其满足时才升级,不满足时不升级、不更新注册表OneKey驱动版本号。
    3. 当华为电脑管家再次检查驱动更新时, OneKey 驱动OTA包的版本号比注册表新,会再次提醒更新。

    环境条件:

    1. Winpe分区存在并且在sources目录下有boot.wim文件;
    2. OneKey分区存在并且在image目录下install.wim文件;
    3. C盘C:\Recovery\OEM目录下存在version.txt文件。

    查看Winpe/Onekey分区文件的方法:

    1. 在管理员权限下打开cmd,执行 diskpart
    2. 执行list vol
    3. 执行sel vol + WinPE/Onekey分区ID(list vol查询出来的序号)
    4. ass
    5. 若需要取消隐藏分区,需重新执行步骤1-3并将步骤4修改为remove
     
    1. 前2个环境条件是执行恢复功能的必要条件,缺少其中任何一个条件,即使OneKey驱动更新成功,F10恢复系统功能也不可用。
    2. 第3个环境条件是OneKey驱动判断此计算机是否为华为计算机的依据,如果没有,不执行升级程序。常有自行安装了操作系统,导致无version.txt文件。

    解决方案

    1. 针对不满足第1个环境条件(无Winpe分区或者存在Winpe分区但sources目录下没有boot.wim文件)出现的问题,解决方案是:

      升级管家到10.0.5.60及其之后版本(新管家增加了升级条件的检测,不符合条件的计算机,将不提示升级),使用新管家重新检测更新。

      第一步: 计算机联网,打开电脑管家>电脑优化,并点击右上角的检查更新:

      第二步: 点击“立即更新”,升级电脑管家:

      第三步: 完成之后,重新打开电脑管家>电脑优化,不提示“OneKey驱动待更新”:

    2. 针对不满足第2个环境条件(无OneKey分区或者存在OneKey分区但image目录下无install.wim文件)出现的问题,解决方案是:

      升级管家到10.0.5.60及其之后版本,如果提示不消失,修改注册表中OneKey版本号。

      第一步:参照解决方案一升级管家后,打开电脑管家>电脑优化,如果依然提示“OneKey驱动待更新”,进行后续操作。

      第二步:在桌面下方的搜索栏中输入“regedit”,在弹出的匹配项中点击“注册表编辑器”。

      为避免注册表修改错误产生相关风险,请参照Windows 计算机如何备份/恢复注册表数据提前备份注册表并谨慎操作。

      第三步:打开注册表编辑器,依次打开“HKEY_LOCAL_MACHINE”、“SOFTWARE”、“WOW6432Node”、“HuaweiOnekey”,右击新建字符串值,名称为OneKeyVersion”(如果已经存在此项,则不需新建):

      第四步:双击“OneKeyVersion“,修改”数据数值“为待更新的OneKey版本号:

      第五步:重新启动电脑,重新打开电脑管家>电脑优化,不提示“OneKey驱动待更新”:

    3. 针对不满足第3个环境条件出现的问题,解决方案是:

      在C:\Recovery\OEM 目录下新建空白的version.txt文件,使用管家重新检测更新。

      第一步: 进入此电脑,点击查看,勾选“隐藏的项目”:

      第二步:进入C:\Recovery\OEM 目录下,右击,新建空白的version.txt文件:

      第三步:打开电脑管家>电脑优化,检测并更新OneKey驱动:

      第四步:重新启动计算机,打开电脑管家>电脑优化,不提示“OneKey驱动待更新”:

    仍未解决?

    如果以上方法仍未解决您的问题,请您提前做好数据备份和记录好Office激活帐号将计算机进行F10恢复出厂设置。若无效,请您携带设备和相关凭证前往华为客户服务中心检测(温馨提示:前往华为客户服务中心前,您可提前拨打电话950800联系服务店了解相关维修情况),我们将竭诚为您服务,祝您生活愉快!

    是否有帮助?
    谢谢您的鼓励!