目录
选择版本

    PC应用市场应用无法下载/安装/安装进程停止

    适用产品: 台式机,笔记本
    适用版本: Windows 10, Windows 11
    适用产品:
    适用版本:
    为您查询到以下结果,请选择
    无法查询到结果,请重新选择
    zoom in pic
    PC应用市场应用无法下载/安装/安装进程停止

    问题现象

    在PC应用市场上无法下载应用,提示下载错误,下载好的应用无法安装,或者提示安装进程停止

    问题原因

    1. 可能是当前电脑登录帐户为子帐户,下载安装目录控制权限不足,无修改写入权限,或下载目录权限被修改导致异常。
    2. 可能是PC应用市场设置的下载路径存在问题。
    3. 可能是PC应用市场当前版本过低导致。
    4. 可能是电脑连接的网络存在异常。
    5. 可能是被第三方软件管家拦截导致。

    解决方案

    无法下载:

    下载提示错误问题已在2.1.2.303版本修复,请您前往PC应用市场 > 设置 > 关于 > 检查更新将版本更新至2.1.2.303版本解决。

    若新版本仍提示下载错误,请按最下方操作方式提供PC应用市场log日志文件,并上传提交问题与建议反馈日志信息,以便我们进一步分析优化,然后再操作添加权限组解决。

    1. 若仍然无效,PC应用市场下载提示错误按以下方法排查:

      (1)通过PC应用市场右上角下载列表 > 下载目录 > 右键点击AppGallery文件夹 > 属性 > 安全 > 查看当前文件夹是否有名为Authenticated Users的组或用户名

      • 如果有组或用户名为Authenticated Users,请确保该帐户有勾选上修改、读取和执行、列出文件夹内容、读取、写入权限,若无请点击选中Authenticated Users > 编辑 > 将所有权限勾选上 > 点击确定,然后重新下载应用尝试。
      • 如果没有Authenticated Users,在PC应用市场右上角下载列表 > 下载目录 > 右键AppGallery文件夹 > 属性 > 安全 > 编辑 > 添加Authenticated Users并且勾选修改、读取和执行、列出文件夹内容、读取、写入权限 > 点击确定,然后重新下载应用尝试。(如下方视频操作)

        (2)每次启动应用市场请右键点击应用市场图标 > 以管理员身份运行后再尝试重新下载。

    2. 应用市场的软件默认下载路径为系统D盘,如您的电脑无D盘,请在PC应用市场 > 设置 > 默认下载目录,修改您的默认下载路径。
    3. 如下载路径无问题,请尝试在PC应用市场 > 设置 > 关于 > 检查更新,将应用市场升级为最新版本。
    4. 检查电脑连接的网络是否存在异常,点击电脑桌面右下角WLAN标志,切换其它WIFI使用或者使用网线接入网络后再下载。
    5. 重启电脑设备后,重新进入应用市场再下载尝试。
    6. 点击电脑桌面左下角菜单 > 控制面板 > 卸载程序 > 在程序列表中找到Appgallery > 右键选择卸载,卸载后,重新通过电脑管家侧边栏安装,或者前往网页版下载最新版本PC应用市场安装,再打开下载应用尝试。

    无法安装/提示安装进程停止:

    1. 关闭360、联想等三方软件管家后台运行,防止管家类软件恶意拦截,关闭后,再重新尝试在应用市场安装。
    2. 安装应用时,需要在系统提示“你要允许此应用对你的设备进行更改吗”时,选择“是”。
    3. 重启电脑设备后,重新进入应用市场再下载尝试。

    如以上方案尝试后,仍然无法下载/安装,提供PC应用市场日志方法:

    1. C:\Users\用户名\AppData\Roaming\appGallery\log路径,将log日志文件邮件发送给客服。
    2. PC应用市场 > 设置 > 关于 > 问题与建议“中描述您的问题,并勾选共享系统日志信息提交日志,我们在分析后将尽快给您答复。

    提交时请备注您的问题并提供给客服人员记录应用市场设备ID,以便提取您上传的日志信息,设备ID查询方法:

    • 1.5.0.300及以上版本PC应用市场,在设置>关于>页面底部有设备ID,点击并复制即可。

    • 若无法在应用市场内复制设备ID,电脑左下角搜索框输入注册表>打开注册表编辑器>复制输入这个路径进行搜索:计算机\KEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Cryptography->找到MachineGuid,拷贝对应的值

      (若找不到搜索框请右键电脑底部状态栏 > 搜索 > 显示搜索框

    是否有帮助?
    谢谢您的鼓励!

    华为终端客户服务微信公众号

    华为终端客户服务微信公众号
    小程序二维码

    扫一扫,打开华为终端客户服务小程序

    为华为全场景产品提供一站式在线服务
    微信公众号

    扫一扫,关注华为终端服务微信公众号

    为消费者提供方便、快捷、贴心的服务
    Notice
    尊敬的客户,现诚邀您对我们的服务质量进行评价。
    本次调查已在浏览器窗口中打开,可在完成本页面访问后前往作答。
    关闭
    调查问卷