目录
选择版本
    华为天气定位异常/定位不准
    适用产品: 手机,平板
    适用版本: Magic UI, HarmonyOS 3.1, HarmonyOS 4.0, HarmonyOS 4.3, HarmonyOS 4.2, HarmonyOS 2.1, HarmonyOS 3.0, HarmonyOS 2.0, EMUI, HarmonyOS 2.0.1
    适用产品:
    适用版本:
    为您查询到以下结果,请选择
    无法查询到结果,请重新选择
    zoom in pic
    华为天气定位异常/定位不准

    问题现象

    华为天气App定位异常,场景包括:

    • 无法定位当前位置。
    • 定位不准,如:实际在城市A,定位显示在城市B。
    • 定位更新慢,如:已从城市A去往了城市B,但定位半小时之后才更新为城市B。

    问题原因

    1. 用户天气定位权限未开启。
    2. 手机系统定位不准。
    3. 天气数据服务商定位不准。

    解决方案

    1. 检查华为天气App位置权限和位置信息是否开启
      • 位置权限检查路径: 打开手机的设置>应用/应用和服务>应用管理,搜索天气,点击权限,打开位置信息开关,选择始终允许
      • 位置信息检查路径: 手机桌面顶部右上角下拉>控制中心>位置信息打开

    2. 系统版本HarmonyOS 3.0以上手机可尝试打开精确位置

      精确位置打开路径:打开手机设置>应用/应用和服务>应用管理,搜索天气,点击权限,打开位置信息开关,选择精确位置

    3. 检查并更新HMS Core(华为移动服务)到最新版本

      检查与更新路径:打开应用市场,搜索HMS Core。若右侧显示打开,即为最新版本;若显示更新,则点击更新即可更新至最新版本。

    4. 检查手机系统定位是否正常

      检查方法:打开指南针,等到指南针停止后是否能显示经度和纬度?能显示代表正常,不能显示则代表系统定位异常。

      说明:仅判断是否显示经纬度即可,无需判断经纬度是否准确。

    5. 清除天气数据后重新进入定位

      操作路径:手机设置>应用/应用和服务>应用管理>天气>存储>删除数据

    6. 修正定位

      目前14.0.10.300以上版本已支持手动修正定位,可通过点击首页定位小标,选择反馈并校准位置进入,拖拽定位标至正确位置或直接搜索正确位置,确认位置后勾选共享应用日志提交即可完成位置修正,具体操作参考下图。

      注:14.0.10.300以下版本不支持此功能,请先到应用市场搜索“华为天气”升级版本。

    7. 如实际位置距离定位位置<500m

      此问题是由于当前的定位精度不够才导致的偏差,后续我们将会提升定位精度来解决此类问题。

    8. 如实际位置距离定位位置>500m

      收集以下信息提交“问题与建议”:

    • 当前正确位置的城市名称(例如:某省、某市、某区、某地)
    • 当前错误定位的城市名称
    • 复现问题故障截图/录屏

      提交路径:天气首页>右上角四个点>我的>帮助与客服>问题与建议需勾选日志提交

      提交成功后我们会在1-2周处理您的问题,辛苦耐心等待。

    是否有帮助?
    谢谢您的鼓励!