目录
选择版本

    华为天气定位异常/定位不准

    适用产品: 手机,平板
    适用版本: Magic UI, HarmonyOS 3.1, HarmonyOS 4.0, HarmonyOS 4.3, HarmonyOS 4.2, HarmonyOS 2.1, HarmonyOS 3.0, HarmonyOS 2.0, HarmonyOS 2.0, EMUI, HarmonyOS 2.0.1
    适用产品:
    适用版本:
    为您查询到以下结果,请选择
    无法查询到结果,请重新选择
    zoom in pic
    华为天气定位异常/定位不准

    问题现象

    定位位置与实际位置不符,或无法定位。

    问题原因

    1.用户天气定位权限未开启;用户未开启精确定位;系统定位不准;天气数据服务商定位不准;

    2.为了避免频繁定位导致手机耗电过快,天气组件每半小时刷新一次,并非实时刷新;

    3.街道级定位包含地标/街道/乡镇,街道级定位不准,可能是因为部分地区没有地标/街道的网点,则会取附近乡镇的网点作为定位。

    解决方案

    1. 检查天气位置权限是否开启
      • 位置权限检查路径: 打开手机/平板的设置>应用/应用和服务>应用管理,搜索天气,点击权限,打开位置信息开关,选择始终允许
      • 位置信息检查路径: 手机/平板桌面顶部右上角下拉>控制中心>位置信息打开。

    2. 检查手机系统定位是否正常

      打开指南针,等到指南针停止后看看是否能显示经度和纬度。

      能显示代表正常,不能显示则代表系统定位异常。

    3. 修正定位

      目前14.0.10.300以上版本已支持手动修正定位,可通过点击首页定位小标,选择反馈并校准位置进入,拖拽定位标至正确位置或直接搜索正确位置,确认位置后勾选共享应用日志提交即可完成位置修正,具体操作参考下图。

      注:14.0.10.300以下版本不支持此功能,请先到应用市场搜索“华为天气”升级版本。

    4. 如实际位置偏差至附近楼栋或街道

      此问题是由于当前的定位精度不够才导致的偏差,后续我们将会提升定位精度来解决此类问题。

    5. 如实际位置偏差至其他行政区或城市

      您可以向我们反馈问题,提交路径:

      天气右上角四个点>我的>帮助与客服>问题与建议

      提交成功后我们会在1-2周处理您的问题,辛苦耐心等待。

    是否有帮助?
    谢谢您的鼓励!