启动华为移动应用引擎或安装移动应用后,弹框提示操作失败
适用产品:
HUAWEI MateBook 13s( intel i5/16g/512g/集显/触屏、 intel i7/16g/512g/集显/触屏、 intel i5/8g/512g/集显/触屏),HUAWEI MateBook 14s( intel i5/16g/512g/集显/触屏、intel i7/16g/1tb/集显/触屏、 intel i7/16g/512g/集显/触屏、 intel i5/8g/512g/集显/触屏),HUAWEI MateStation X(2023 i9/16gb/ 512gb /ssd /集显、2023 i5/16gb/512gb/ssd /集显、2023 i9/16gb/1t /ssd/集显)
适用版本:
Windows 10, Windows 11
适用产品:
适用版本:
为您查询到以下结果,请选择
无法查询到结果,请重新选择
启动华为移动应用引擎或安装移动应用后,弹框提示操作失败 |
问题现象
启动华为移动应用引擎,或者从应用市场安装移动应用后,弹框提示操作失败。
问题原因
华为移动应用引擎在启动时会对您的身份信息进行校验,以保证您的数据安全性。恢复出厂设置、更新系统版本等可能导致您的身份令牌信息变化,导致校验失败。
为了确保您的数据安全性,在无法验证用户身份时,华为移动应用引擎要求先清理旧的应用数据,初始化引擎后才能够使用。
解决方案
方案一:
如果是预置机器(HUAWEI Matebook 13s,HUAWEI Matebook 14s),使用过华为移动应用引擎后又将电脑恢复了出厂设置,再次打开华为移动应用引擎出现该弹窗,那么需要将华为移动应用引擎升级到最新版本。新版本的华为移动应用引擎会提供一键删除数据接口方便进行清理,点击删除后再重新打开华为移动应用引擎即可。
升级方式
保持网络畅通,点击
,进行升级安装。如果找不到该快捷方式,可以打开目录C:\Program Files\MobileAppEngine\qemu\windows-x86_64,双击MobileAppEngineUpdate.exe,也可打开升级界面。
方案二:
该操作会导致华为移动应用引擎产生的应用数据被删除。
首先点击知道了关闭该窗口。打开华为移动应用引擎的数据目录(默认为D:\Program Files\MobileAppEngine\emui;如果电脑只有C盘,那么为C:\Program Files\MobileAppEngine\emui;如果安装时自行选择过安装目录,那么为自己选择的目录下的Emui目录),删除该目录下所有文件,然后再次从应用市场安装其他移动应用即可。
谢谢您的鼓励!