目录
选择版本

    华为计算机运行移动应用引擎时,提示“检测到您的虚拟化设置异常,请手动修改后重新操作”

    适用产品: 台式机,笔记本
    适用版本: Windows 10, Windows 11
    适用产品:
    适用版本:
    为您查询到以下结果,请选择
    无法查询到结果,请重新选择
    zoom in pic
    华为计算机运行移动应用引擎时,提示“检测到您的虚拟化设置异常,请手动修改后重新操作”

    问题现象

    计算机运行移动应用引擎时,提示检测到您的虚拟化设置异常,请手动修改后重新操作

    问题原因

    运行移动应用引擎需要关闭Hyper-V,因此对于需要基于Hyper-V的虚拟机(例如:WSL2、WSA等)不能与移动应用引擎同时运行。

    解决方案

     

    方法一:工具操作关闭

    1. 点击下载压缩包Tools.rar,解压文件后找到Tools.exe,双击打开Tools.exe。

    若下载后提示病毒,无法安全下载,请参考《华为计算机使用Edge浏览器下载文件提示“无法安全下载》。

    2. 重启出现英文页面后,按界面提示点按4F3则表示同意关闭虚拟机,等待电脑启动后完成操作。

    方案二:使用第三方软件关闭Hyper-V。

    1. 下载并安装模拟器,选择默认安装即可。
    2. 运行模拟器,会提示电脑开启了虚拟服务,点击“重启电脑”即可完成修复。

    3. 卸载模拟器。

    仍未解决?

    如果以上方法未能解决您的问题,请您提前做好数据备份和记录好Office激活帐号将计算机进行F10恢复出厂设置。若无效,请您携带设备和相关凭证前往华为客户服务中心检测(温馨提示:前往华为客户服务中心前,您可提前拨打电话950800联系服务店了解相关维修情况),我们将竭诚为您服务,祝您生活愉快!

    是否有帮助?
    谢谢您的鼓励!