当智能场景的触发条件含WLAN能力时,场景执行失败或提示网络未连接
适用产品:
HiLink生态产品
适用版本:
不涉及系统版本
适用产品:
适用版本:
为您查询到以下结果,请选择
无法查询到结果,请重新选择
当智能场景的触发条件含WLAN能力时,场景执行失败或提示网络未连接 |
问题现象:
当智慧生活App智能场景的触发条件含WLAN能力时,该场景偶尔会执行失败或App提示网络未连接。
WLAN相关能力包括:开启WLAN、关闭WLAN、WLAN连接指定网络、WLAN断开指定网络等。
问题原因:
在执行此类场景时,存在因手机/平板切换网络的速度慢而出现短暂无网络情况的可能。此类场景需在手机/平板联网状态下才能执行。
解决方案:
您可以添加某个手机/平板系统功能作为首个执行任务,并设置延时执行,建议设置延时的时长至少为2秒,以确保场景的其他任务可以在手机/平板恢复联网后正常执行。
- 手机/平板系统功能包括:手机振动、语音播报、手机亮度调节等。
- 不同手机支持的系统功能不同,请以实际为准。
- 手机/平板可在未联网时执行系统功能。
- 当设置触发条件为“WLAN连接指定网络”的场景,需要打开系统的位置信息开关,场景才可以正常执行。(HarmonyOS 5版本手机不涉及,请跳过此步骤。)
仍无法解决?
如果尝试上述方法仍无法解决,请通过以下操作反馈问题:
(1)智慧生活App>场景>我的场景>右上角四个点“”>执行日志>截图。
(2)智慧生活App>我的>帮助与反馈>智能场景>反馈问题,点击+号添加截图,感谢您的支持。
如果以上方法未能解决您的问题,请您致电华为客户服务热线:950800,我们将竭诚为您服务,祝您生活愉快!
谢谢您的鼓励!