目录
选择版本
    华为计算机无法共享打印机或连接共享打印机提示“连接失败”
    适用产品: 台式机,笔记本
    适用版本: Windows 10, Windows 11
    适用产品:
    适用版本:
    为您查询到以下结果,请选择
    无法查询到结果,请重新选择
    zoom in pic
    华为计算机无法共享打印机或连接共享打印机提示“连接失败”

    问题现象

    计算机连接共享打印机失败,搜索不到共享打印机或连接打印机时提示“无法连接,错误代码0X***”。

    问题原因

    共享端或访问端网络问题或共享设置以及系统等因素导致。

    解决方案

    请您尝试以下方案进行处理

    A计算机为已连接打印机电脑、B计算机为未连接打印机电脑。

    1. 请您检查A计算机所连接打印机处于开机并就绪状态,B计算机参照华为计算机如何连接共享打印机重新连接打印机。
    2. 重启A、B计算机相关打印服务项,具体步骤如下:将附件脚本文件下载并保存至计算机的桌面,解压缩后右键点击“以管理员身份运行”,运行完成后,请重启计算机即可。
    3. 为保证系统稳定性,建议您提前做好重要数据备份后将B计算机Windows系统更新至最新版本。等待Windows系统更新完成后,B计算机参照华为计算机如何连接共享打印机重新连接打印机。
    1. 使用打印机修复工具进行系统修复,具体步骤如下:
      1. 下载共享打印机修复工具.zip(此工具23H2及以上版本均可尝试使用),使用解压软件将文件解压。
      2. 打开Windows设置>系统>系统信息/关于,查看并确认Windows系统版本。
      3. 选择与Windows系统版本相对应打印机修复工具,并以管理员身份运行里面的 fix-printer.bat文件。
      4. 修复完成后,请立即重启计算机后重新连接打印机尝试。
       
      • 华为打印机不支持此修复工具。
      • 使用共享打印机修复工具修复,可能会出现打印机未连接现象,出现此现象后,尝试在此使用修复工具修复操作。
    2. 如果您的计算机Windows系统版本为22H2,请您同时按住Win+R键打开运行框,在运行窗口后输入“regedit”回车,打开注册表编辑器。

      为避免注册表修改错误产生相关风险,请参照Windows 计算机如何备份/恢复注册表数据提前备份注册表并谨慎操作。

      1. 在注册表中找到此位置:计算机\HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Print

      2. 空白处右键新建选择“DWORD (32位)值” ,命名为 RpcAuthnLevelPrivacyEnabled,之后双击此项目,将数值设为0

      3. 设置完成后,点击确认保存退出。注册表修改完成后,请按照步骤4下载打印机修复工具进行系统修复,等待系统修复完成后,请立即重启计算机并连接共享打印机尝试。
    3. 使用A电脑的用户名访问共享打印机尝试。
    4. 访问端添加共享名称GUEST:左下角放大镜中搜索控制面板,打开控制面板>查看类型(方式)选择“小图标”>凭据管理器,选中Windows凭据添加Windows凭据。在Internet地址或网络地址选项填写访问的打印机服务器共享路径IP地址,将用户名填写为GUEST,密码为空,再重启PC尝试解决。

    仍未解决?

    如果以上方法未解决您的问题,请您随时联系我们售后(华为消费者服务热线 950800),我们将竭诚为您服务,祝您生活愉快!

    是否有帮助?
    谢谢您的鼓励!