目录
选择版本
    智慧屏已安装的应用内无法更新
    适用产品: 智慧屏
    适用版本: HarmonyOS 3.1, HarmonyOS 4.0, HarmonyOS 4.3, HarmonyOS 4.2, HarmonyOS 2.0, HarmonyOS 2.1, HarmonyOS 3.0, HarmonyOS 2.0.1
    适用产品:
    适用版本:
    为您查询到以下结果,请选择
    无法查询到结果,请重新选择
    zoom in pic
    智慧屏已安装的应用内无法更新

    问题现象

    智慧屏已安装的应用内提示更新,但是点击立即更新后,查看版本显示为打开,无法更新至新版本。

    问题原因

    智慧屏上的在架应用是通过应用中心渠道更新,如未开启应用更新开关,应用中心无法获取智慧屏上的已安装应用列表,导致不能更新。

    解决方案

    1. 检查路由器是否开启儿童模式保护,该保护会导致应用中心无法更新应用,请关闭后再尝试更新应用。华为路由器参考:路由器设置儿童上网保护
    2. 如当前连接WLAN网络无法更新,请尝试更换网络后查看是否可正常更新(如使用手机移动数据热点)。
    3. 首次打开智慧屏应用中心留意弹窗提示

      应用中心在首次进入时会弹窗提示是否开启应用更新功能,请留意选择开启。

    4. 检查智慧屏应用中心更新开关

      请前往应用中心>我的>检查更新,确认开启应用更新开关,然后再通过应用中心 > 我的 > 更新管理,找到需要更新的应用,选择更新尝试是否成功。或直接打开对应的应用,通过应用内的提示再进行更新操作。

      应用中心暂不支持灵犀遥控操作功能,如操作使用灵犀遥控打开该开关,实际开关并未生效。

      如何关闭指向遥控,参考:华为智慧屏灵犀指向遥控功能介绍

    是否有帮助?
    谢谢您的鼓励!