目录
选择版本

    升级HarmonyOS 5时提示“华为应用市场数据升级相关服务获取失败”

    适用产品: 手机,平板
    适用版本: HarmonyOS 5.0以下
    适用产品:
    适用版本:
    为您查询到以下结果,请选择
    无法查询到结果,请重新选择
    zoom in pic
    升级HarmonyOS 5时提示“华为应用市场数据升级相关服务获取失败”

    问题现象

    设置 > 系统和更新 > 软件更新,选择升级至HarmonyOS 5时,会弹窗提示"华为应用市场数据升级相关服务获取失败,请稍后重试"问题。

    问题原因

    因设备安装了众测beta版本的应用市场,导致申请升级至HarmonyOS 5过程中时,可能会引发升级异常。

    解决方案

    您好,很抱歉给您带来不便,请您参考以下方式解决。

    请打开设置 > 应用和服务 > 应用管理 > 华为应用市场,确认应用市场版本号是否为14.2.1.200_beta/15.1.1.200beta。

    1. 如是该版本,请在该界面点击右上角四个点,选择卸载更新,应用市场,操作完成后,再前往设置 > 系统和更新 > 软件更新,重新选择升级系统尝试。
    2. 如非该版本,请操作设置 > 应用和服务 > 应用管理 > 华为应用市场 > 存储 > 删除数据设置 > 应用和服务 > 应用管理 > 软件更新 > 存储 > 删除数据,操作完成后,再前往设置 > 系统和更新 > 软件更新,重新选择升级系统尝试。

      如上述操作未解决,请您复现问题后前往应用市场 > 我的 > 帮助与客服 > 问题与建议,勾选共享日志并提交。然后前往应用市场 > 我的 > 帮助与客服,联系在线客服提供设备SN,并反馈问题编号及您的问题录屏。并联系华为客服抓取您的设备整机系统日志,以便我们进一步分析处理,谢谢

    是否有帮助?
    谢谢您的鼓励!