目录
选择版本

    天气定位异常/定位不准

    适用产品: 手机,平板
    适用版本: HarmonyOS 5.0, HarmonyOS 5.1
    适用产品:
    适用版本:
    为您查询到以下结果,请选择
    无法查询到结果,请重新选择
    zoom in pic
    天气定位异常/定位不准

    问题现象

    华为天气App定位异常,场景包括:

    1. 无法定位当前位置;
    2. 定位不准,如:实际在地点A,定位显示在地点B;
    3. 天气组件定位更新慢,如:已从地点A去往了地点B,但天气组件定位半小时之后才更新为地点B;(属于非问题)
    4. 开启街道级定位,只定位到乡镇,定位不到那么细。(属于非问题)

    问题原因

    1~2:用户天气定位权限未开启;系统定位不准;天气数据服务商定位不准;用户未开启精确定位;

    3:由于系统能耗限制,天气组件存在半小时刷新一次的机制,并非实时刷新;

    4:街道级定位包含地标/街道/乡镇,定位显示取决周围的网点情况,部分地区不存在地标/街道的网点,则会取附近乡镇的网点作为定位。

    解决方案

    1. 检查华为天气App位置权限和精确位置是否开启。

      检查路径: 手机设置>应用和元服务>天气>位置,选择始终允许及打开精确位置

    2. 检查是否打开访问我的位置。

      检查路径:手机设置>隐私和安全>位置,打开访问我的位置

    3. 检查手机系统定位是否正常

      检查方法:打开指南针,等到指南针停止后是否能显示经纬度?能显示经纬度代表正常,否则异常。

      说明:仅判断是否显示经纬度即可,无需判断经纬度是否准确。

    4. 如实际位置距离定位位置<500m

      此问题是由于当前的定位精度不够才导致的偏差,后续我们将会提升定位精度来解决此类问题。

    5. 如实际位置距离定位位置>500m

      收集以下信息提交问题与建议

    • 当前正确位置的城市名称(例如:某省、某市、某区)
    • 当前错误定位的城市名称
    • 复现问题故障录屏或截图

      提交路径:天气首页>右上角四个点>帮助与客服>问题与建议,需勾选日志提交,我们会在一周内处理您的问题。

    是否有帮助?
    谢谢您的鼓励!