目录
选择版本

    天气定位异常/定位不准

    适用产品: 手机,平板
    适用版本: HarmonyOS 5.0及以上
    适用产品:
    适用版本:
    为您查询到以下结果,请选择
    无法查询到结果,请重新选择
    zoom in pic
    天气定位异常/定位不准

    问题现象

    定位位置和实际位置不符,或无法定位。

    问题原因

    1.天气定位权限未开启;未开启精确定位;系统定位不准;天气数据服务商定位不准;

    2.为了避免频繁定位导致手机耗电过快,天气组件每半小时刷新一次,并非实时刷新;

    3.街道级定位包含地标/街道/乡镇,部分地区没有地标/街道的网点,则会取附近乡镇的网点作为定位。

    解决方案

    *以下图片为手机示意图,请以实际产品为准。

    1. 检查天气App位置权限和精确位置是否开启。

      设置>应用和元服务>天气>位置,选择始终允许及打开精确位置

    2. 检查是否打开访问我的位置。

      设置>隐私和安全>位置,打开访问我的位置

    3. 检查设备系统定位是否正常

      打开指南针,等到指南针停止后看看是否能显示经纬度。能显示经纬度代表正常。

    4. 校准定位

      目前15.0.12.300以上版本已支持手动校准定位,可通过点击首页定位小标,选择位置反馈,拖拽定位标至正确位置或直接搜索正确位置,确认位置后提交即可完成位定位校准,具体操作参考下图。

    5. 如定位偏差至附近街道或楼栋

      此问题是由于当前的定位精度不够才导致的偏差,后续我们将会提升定位精度来解决此类问题。

    6. 如定位偏差至其他行政区或城市

      您可以向我们反馈问题,提交路径:天气首页右上角四个点>帮助与客服/帮助和反馈>问题与建议,我们会在三个工作日内处理您的问题。

    是否有帮助?
    谢谢您的鼓励!