目录
选择版本
    华为计算机系统更新失败或报错
    适用产品: HUAWEI MateStation X,HUAWEI MateStation X(2023 i9/16gb/ 512gb /ssd /集显、2023 i9/16gb/1t /ssd/集显),笔记本
    适用版本: Windows 10, Windows 11
    适用产品:
    适用版本:
    为您查询到以下结果,请选择
    无法查询到结果,请重新选择
    zoom in pic
    华为计算机系统更新失败或报错

    问题现象

    计算机在升级过程中出现报错,错误代码为0x80248007/ 0x80240034/ 0x80070422/0x80080005等。

    问题原因

    • 当前网络状况不佳。
    • 微软服务器出现异常,获取服务器数据失败。
    • Windows Update 或Windows更新服务项运行状态异常。

    解决方案

    在执行以下操作前,请您先进行数据备份和记录好Office激活帐号。

    1. 请更换时间或更换网络(如连接手机热点、USB转接手机移动共享网络或有线网络等)重新进行Windows系统更新。

      通过 USB 有线共享网络:

      1. 使用 USB 数据线将手机(安卓或HarmonyOS)与电脑连接。
      2. 在手机上进入设置 > 移动网络 > 个人热点 > 更多共享设置,开启 USB 共享网络开关,共享移动网络或已连接的WLAN网络给电脑。
    2. 重新启动Windows Update服务,具体操作步骤如下:
      1. 右键点击系统桌面左下角的开始菜单,点击运行

      2. 在打开的运行对话框中输入“services.msc”命令,点击确定

      3. 在弹出的服务窗口,找到“Windows Update”,双击“Windows Update”;

        若您的计算机是Windows11系统,此处显示为Windows更新

      4. 启用类型选自动,服务状态点击“启动(S)”,然后点击下面应用,然后点确定就可以了。

    3. 在任务栏左下角搜索框输入cmd后以管理员身份运行此命令提示符。

      然后输入以下4行命令后分别按回车键执行:

      net stop wuauserv

      net stop cryptSvc

      net stop bits

      net stop msiserver

      再输入以下命令行分别按回车键执行更改对应文件名称:

      ren C:\Windows\SoftwareDistribution SoftwareDistribution.old

      ren C:\Windows\System32\catroot2 Catroot2.old

      输入以下5行命令后分别按回车键启用服务项:

      net start wuauserv

      net start cryptSvc

      net start bits

      net start msiserver

      netsh winsock reset

      执行完成以上命令行后,重启计算机。

    4. 出现报错时,系统页面一般会有相关联代码提示(例如 KB5029263,您可以进入微软网站下载对应的更新包,手动安装更新。具体操作步骤如下:
      1. 右上角输入框输入对应更新包的代码(例如 KB5029263)点击Search

      2. 根据您电脑的操作系统,点击右侧Download下载。

      3. 下载完成后,按照提示安装即可。

      4. 安装完成,请重启计算机。

    仍未解决?

    如果以上方法仍未解决您的问题,请您提前做好数据备份和记录好Office激活帐号将计算机进行F10恢复出厂设置。若无效,请您携带设备和相关凭证前往华为客户服务中心检测(温馨提示:前往华为客户服务中心前,您可提前拨打电话950800联系服务店了解相关维修情况),我们将竭诚为您服务,祝您生活愉快!

    是否有帮助?
    谢谢您的鼓励!