目录
选择版本
    华为计算机安装某些应用程序或驱动后提示“无法开启内存完整性”
    适用产品: 台式机,笔记本
    适用版本: Windows 11
    适用产品:
    适用版本:
    为您查询到以下结果,请选择
    无法查询到结果,请重新选择
    zoom in pic
    华为计算机安装某些应用程序或驱动后提示“无法开启内存完整性”

    问题现象

    计算机安装某些应用程序或驱动后提示无法开启内存完整性

    问题原因

    某些驱动文件签名或第三方应用软件相关程序不兼容导致。

    可参考微软官网说明:无法在此设备上加载驱动程序现象

    解决方案

    1. 请在任务栏搜索框输入安全中心,打开后,点击设备安全性>内核隔离详细信息,再点击忽略即可,将某些驱动文件签名或相关三方应用软件程序的兼容性提示进行忽略即可,该操作不影响其正常使用。

    2. 请卸载对应不兼容驱动程序或第三方应用软件,具体步骤如下:

      卸载后将导致无法使用,如果需要使用,请关闭内存完整性选项后再次重新安装,内存完整性选项系统默认为关闭状态。

      1. 手动卸载相关驱动程序:在任务栏搜索框输入安全中心,打开后,点击设备安全性>内核隔离详细信息>查看不兼容的驱动程序,展开后显示不兼容驱动列表。

      2. 在计算机系统文件资源管理器里面搜索相应不兼容程序的文件名称,手动删除。
         
        • 卸载后将导致无法使用,如果需要使用,请关闭内存完整性选项后,重新安装最新版本驱动程序或应用程序即可。
        • 很多文件手动删除会提示权限不足或被占用无法进行删除,这些文件可能需要管理员权限或将对应的应用程序进程结束后再操作,可以将文件后缀名改为txt,然后再删除。
        • 部分驱动无法卸载(搜不到,删不了,删除又会有,安全模式也无法删除),通过步骤a显示的驱动发布名称,可以尝试如下方法:
          1. 开始菜单右键,选择Windows PowerShell(管理员)(A)。
          2. Windows PowerShell(管理员)(A))中列出所有驱动,输入:pnputil /enum-drivers
          3. 删除不兼容的驱动(点击查看不兼容的驱动程序查看),终端(管理员)中输入:pnputil /delete-driver 要删除驱动名称(如:oem32.inf)。

          4. 删除时请谨慎操作,注意不要删除其他正常的驱动,以免计算机系统功能异常。
        • 另外,也可以借助第三方软件强力删除等,删除完成后重新开启内存完整性开关并根据提示重启生效即可。
    3. 请确认是否有安装华为手机助手,若有安装,请按照如下步骤卸载华为手机助手以及通过华为手机助手安装的驱动:

      如果进行如下操作,需要保证电脑端有安装华为手机助手应用。

      1. 键盘上的Windows + R键,输入“%temp%/../hiSuite”并打开。

      2. 通过如下路径userdata>driver>all>DriverUninstall. 单击右键以管理员身份运行。

      3. 返回Windows上的内核隔离。尝试再次打开内存完整性

      4. 如果还是无法打开内存完整性,请单击“查看不兼容的驱动程序”,您可能会看到驱动程序,相关驱动文件还有残留,请手动卸载。

      5. 手动卸载具体方法:在C:\Windows\System32\drivers路径下,找到名为“ew_usbccgpfilter.sys”的驱动程序,然后删除。

    仍未解决?

    如果以上方法仍未解决您的问题,请您提前做好数据备份和记录好Office激活帐号将计算机进行F10恢复出厂设置。若无效,请您携带设备和相关凭证前往华为客户服务中心检测(温馨提示:前往华为客户服务中心前,您可提前拨打电话950800联系服务店了解相关维修情况),我们将竭诚为您服务,祝您生活愉快!

    是否有帮助?
    谢谢您的鼓励!