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    华为计算机使用Windows Defender安全扫描时系统运行不流畅

    适用产品: 台式机,笔记本
    适用版本: Windows 10, Windows 11
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    华为计算机使用Windows Defender安全扫描时系统运行不流畅

    问题现象

    计算机Windows Defender使用反恶意软件服务时,该服务的进程Msmpeng.exe会导致系统硬盘和CPU的使用率超过80%,从而造成计算机运行卡顿。

    问题原因

    Msmpeng.exe是属于Windows Defender自动保护服务的核心进程,包括反恶意软件应用程序Microsoft AntiSpywaresoftware的工具组件。

    Windows Defender 预安装在Windows 10和Windows 11上,当Windows Defender扫描系统中是否存在恶意软件时,通常会出现Msmpeng.exe占用CPU使用率高导致系统运行不流畅。

    解决方案

    请您按照以下步骤逐一排查:

    1. 确保没有安装其他反恶意软件或防病毒软件
      请确认计算机中是否有安装第三方反恶意软件或防病毒软件(如**安全卫士、**电脑管家、**毒霸等),由于此类软件可能与Windows Defender、华为电脑管家等存在功能冲突,容易造成系统不稳定。若有,请您参照以下方式进行卸载:
      1. 按下Win+R组合键,调出开始运行窗口。
      2. 在运行窗口中的编辑框内输入appwiz.cpl,然后点击确定按钮。

      3. 鼠标右键点击第三方杀毒软件或管家软件,点击弹出菜单项卸载/更改(U)

    2. 防止Windows Defender扫描系统上的特定文件夹

      高负载的一个原因是Msmpeng.exe扫描特定的文件或文件夹。您可以添加排除项,让Windows Defender永远不会扫描这些文件或文件夹。添加排除项方法:

      1. 依次点击Windows设置 > 隐私和安全性 > Windows安全中心,打开Windows安全中心

        点击进入Windows安全中心

      2. 单击病毒和威胁防护 > 管理设置, 找到排除项目录,点击添加或删除排除项

      3. 单击+选择进程

        可以选择常用的应用程序(示例哔哩哔哩.exe),同时可以将文件夹C:\Program Files\Windows Defender添加至文件夹排除路径。

    3. 关闭Windows Defender的实时保护

      依次点击Windows设置 > 隐私和安全性 > Windows > 安全中心,点击打开Windows安全中心,弹出的界面找到病毒和威胁防护 > 管理设置实时保护 > 篡改防护 >

      点击进入Windows安全中心

    4. 在计算机任务计划程序中重新安排扫描
      1. 在计算机左下角的搜索框输入任务计划程序单击打开。
      2. 从左边的任务计划程序库中, 依次双击Microsoft > Windows > Windows Defender

      3. 在中间窗格中找到Windows Defender Scheduled Scan双击进入,在常规目录下,取消使用最高权限运行

      4. 转到条件窗口,取消所有勾选后点击确定,即可清除计划扫描。

      5. 再次转到触发器,点击新建,创建扫描计划。

      6. 您可以按照自己的需求创建新的扫描计划,使您在保护计算机和系统效率间取得平衡,确定扫描日期后单击确定

      7. 对以下三个服务重复相同的过程:Windows Defender 清理、Windows Defender 缓存维护和 Windows Defender 验证。

      8. 此过程将根据您的偏好重新安排您计算机的Windows Defender运行。重新启动您的计算机并查看Antimalware Service Executable是否仍在使用高CPU负载。
    5. 通过修改注册表禁用Windows Defender
       
      • 在禁用防病毒应用程序的情况下,您的计算机可能容易受到恶意软件、黑客和其他类型的网络攻击。
      • 为避免注册表修改错误产生相关风险,请参照《华为计算机如何备份/恢复注册表数据》提前备份注册表并谨慎操作。
      • 修改注册表之前需关闭篡改防护,请参考方案3
      1. WIN+R 组合键,打开运行,在搜索框输入regedit,点击确定,快速打开注册表编辑器。
      2. 在注册表编辑器中,跳转到HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows Defender。
      3. 在右侧空白处,右键点击鼠标新建 > DWORD(32位)值,将其命名为DisableAntiSpyware。

      4. 双击DisableAntiSpyware打开,将数值数据修改为1,点击确定,重启计算机。

        若要重新启用Windows Defender,将上述步骤d中DisableAntiSpyware值改为0,重启计算机后即可生效。

    仍未解决?

    如果以上方法仍未解决您的问题,请您做好数据备份和Office激活帐号将计算机F10恢复出厂设置。若无效,请您备份好数据携带设备和相关购机凭证前往华为客户服务中心检测(温馨提示:前往华为客户服务中心前,您可提前拨打电话950800联系服务店了解相关维修情况),我们将竭诚为您服务,祝您生活愉快

    是否有帮助?
    谢谢您的鼓励!