目录
选择版本
    【华为】手表/手环连接三方安卓手机添加常用联系人提示“没有带号码的联系人”/“正在同步”
    适用产品: HUAWEI WATCH GT 2022典藏版,华为手环 10,HUAWEI WATCH GT 3 Pro,HUAWEI WATCH GT Runner,HUAWEI WATCH H5556,HUAWEI WATCH GT Cyber,HUAWEI WATCH 4,HUAWEI WATCH B5,HUAWEI WATCH 3 Pro new,HUAWEI WATCH GT 2 Pro,HUAWEI WATCH 3,HUAWEI WATCH 4 Pro 太空探索,HUAWEI WATCH GT 4 & S-TAG,HUAWEI WATCH 4 Pro,HUAWEI WATCH D2,HUAWEI WATCH GT 5 Pro,HUAWEI WATCH FIT 3,HUAWEI WATCH FIT 2,HUAWEI WATCH GT 2 保时捷设计,HUAWEI WATCH GT 3 | 保时捷设计,HUAWEI WATCH | ULTIMATE DESIGN,华为手环 B6,HUAWEI WATCH B5-736,HUAWEI WATCH 3 Pro,HUAWEI WATCH Ultimate,华为手环 B5,HUAWEI WATCH H5756,华为通话手环 B7,华为擎云H5546,华为擎云H7546,HUAWEI WATCH GT 5,HUAWEI WATCH GT 2,华为擎云 H9D20,华为擎云 HA590,HUAWEI WATCH GT 4,HUAWEI WATCH Buds,HUAWEI WATCH GT 3
    适用版本: 不涉及系统版本
    适用产品:
    适用版本:
    为您查询到以下结果,请选择
    无法查询到结果,请重新选择
    zoom in pic
    【华为】手表/手环连接三方安卓手机添加常用联系人提示“没有带号码的联系人”/“正在同步”

    问题现象:

    • 华为手表/手环连接三方安卓手机,手机中已保存的联系人,在华为运动健康App>设备,点击连接的设备,选择常用联系人,添加常用联系人时失败,提示“没有带号码的联系人”。
    • WATCH 3/WATCH 4系列手表连接三方安卓手机,手机中已有保存的联系人,在手表联系人应用中同步联系人一直提示“正在同步”,无法同步联系人。

    问题原因:

    三方安卓手机有针对应用的保护联系人信息的功能,开启后,系统会提供空的联系人代替真实联系人,避免个人信息泄露;当对华为运动健康App开启该功能,虽然华为运动健康App有读取联系人的权限,但只会获取到空的联系人,因而显示没有带号码的联系人/手表无法同步联系人。

    解决方案:

    建议您在手机上关闭华为运动健康App的保护联系人功能,具体关闭路径建议您咨询三方手机厂商,以下路径仅供参考:

    OPPO手机路径:设置>权限与隐私>隐私替身,找到华为运动健康App,关闭此开关;

    vivo手机路径:设置>应用与权限>权限管理>权限>访问联系人>华为运动健康APP,关闭/不使用提供空白信息,将访问联系人权限设置为允许/始终允许

    小米手机路径:设置>应用设置>找到华为运动健康App>权限管理>读取联系人,关闭/不使用空白通行证,将读取联系人权限设置为允许/始终允许

    一加手机路径:设置>权限与隐私>隐私替身,找到华为运动健康App,关闭此开关。

    如果以上操作仍无法解决您的问题,建议您拨打华为消费者服务热线950800获取更多帮助。

    是否有帮助?
    谢谢您的鼓励!