应用市场切换国家/地区提示“更改失败”
应用市场切换国家/地区提示“更改失败” |
问题现象
在
,操作切换服务地时提示:- “更改失败,您需要到 和 中解约自动续费和关闭免密支付。”
- “更改失败,华为帐号下的华为支付账户未注销。”
- “更改失败,仅当您迁居至新的国家/地区时,才能进行更改。”
- “更改失败,若您绑定过银行卡,365天内只能更改2次国家/地区,您的更改次数已达上限,可在xxx天后更改。”
问题原因
- 更改国家/地区前需满足相关条件才能切换。
- 切换服务地功能仅支持您在出境、移居至新的国家/地区后使用,在中国大陆区域(不含港澳台地区)不支持切换国家/地区功能。
- 在华为帐号绑定银行卡后,切换服务地时会清除您的绑卡数据,且频繁切换服务地可能会被银行风险系统识别为异常操作行为,导致您的银行卡无法正常使用,因此对已绑定银行卡的华为帐号切换服务地设置了次数限制。
解决方案
- 更改服务地前请根据提示取消自动续费、免密支付等功能。
- 取消自动续费: ,将所有自动续费服务取消,在 关闭免密支付功能。
- 注销华为支付:参考如何注销华为支付。
- 关闭家人共享功能:
- 提示“更改失败,仅当您迁居至新的国家/地区时,才能进行更改”,需您到达中国港澳台或海外国家/地区之后进行切换服务地区设置,具体是否支持场景如下
序号
服务地操作切换国家/地区场景
当前所在地理位置
是否支持切换
情况说明
1
从中国大陆(不含港澳台)
切换至
中国港澳台或海外国家/地区
中国大陆(不含港澳台)
不支持
您好,为确保应用市场提供的服务符合不同国家/地区法律法规要求,应用市场服务地需和您所在地保持一致。(例:当前在中国大陆(不含港澳台地区),应用市场仅支持中国大陆服务)
如您需要切换国家/地区,请在到达中国港澳台或海外国家/地区之后进行切换服务地区设置(如移居新的国家地区或短期/长期出境),感谢您的关注!
中国港澳台或海外国家/地区
支持
您好,你可以在应用市场,点击“我的 > 设置 > 国家/地区 > 更改国家或地区,操作切换服务地,切换前请您留意切换国家地区相关注意事项,谢谢。
2
从中国港澳台或海外国家/地区
切换至
其他海外国家/地区
中国大陆(不含港澳台)
不支持
您好,为确保应用市场提供的服务符合不同国家/地区法律法规要求,应用市场服务地需和您所在地保持一致,(例:当前您在中国大陆(不含港澳台),应用市场服务地在海外国家/地区或中国港澳台,不支持再切换至其他海外国家/地区),您可以保持当前服务地使用或操作切换回中国大陆,切换回中国大陆后将不支持切换至其他国家/地区,在您出境或移居至新的国家/地区后,可再次使用切换服务地功能,感谢您的反馈!
中国港澳台或海外国家/地区
支持
您好,你可以在应用市场,点击“我的 > 设置 > 国家/地区 > 更改国家或地区,操作切换服务地,切换前请您留意切换国家地区相关注意事项,谢谢
3
从中国港澳台或海外国家/地区
切换至
中国大陆(不含港澳台)
中国大陆(不含港澳台)
支持
您好,你可以在应用市场,点击“我的 > 设置 > 国家/地区 > 更改国家或地区,将您的服务地切回中国大陆(不含港澳台地区)使用,切换回中国大陆后不支持切换至其他国家/地区,在您出境或移居至新的国家/地区后,可再次使用切换服务地功能。
中国港澳台或海外国家/地区
支持
您好,你可以在应用市场,点击“我的 > 设置 > 国家/地区 > 更改国家或地区,操作切换服务地,切换前请您留意切换国家/地区相关注意事项,谢谢。
- 更改提示365天内仅能切换2次,当前剩余xx天才能切换。
通过中国大陆切换至海外国家/地区,当应用市场处于海外国家/地区服务地时在
进行了绑定,那么在365天内该帐号只能进行切换2次(如果已绑定过银行卡后解绑,次数仍然是2次,无法解除限制)。例:
- 应用市场从中国大陆切换服务地至某海外国家/地区,然后前往帐号绑定银行卡,此时会限制365天仅有2次切换次数。(切换到海外服务地付款与账单绑卡会影响)
- 应用市场处于中国大陆服务地,前往帐号绑定银行卡,此时不影响切换次数。