Mengapa pembayaran dalam aplikasi tidak dapat dilakukan/layanan langganan tidak dapat secara otomatis diperpanjang untuk aplikasi yang diunduh dari HUAWEIAppGallery?
Produk yang berlaku: Tablet,Smartphone
Produk yang berlaku:
Berikut ini hasil yang ditemukan untuk Anda, silakan pilih
Tak dapat menemukan hasil, silakan pilih lagi
zoom in pic
Mengapa pembayaran dalam aplikasi tidak dapat dilakukan/layanan langganan tidak dapat secara otomatis diperpanjang untuk aplikasi yang diunduh dari HUAWEIAppGallery?

Masalah:

  • Kegagalan pembayaran: Pembayaran dalam aplikasi gagal, tetapi tidak ada pesan kesalahan yang menunjukkan mengapa hal tersebut gagal.
  • Layanan langganan: Langganan aktif tidak dapat diperpanjang secara otomatis.

Penyebab:

Jika aplikasi/game tidak didistribusikan di kawasan layanan yang telah Anda tetapkan untuk klien HUAWEIAppGallery Anda, Anda tidak akan dapat melakukan pembayaran di dalamnya, tetapi layanan aplikasi/game yang dibeli sebelumnya masih akan valid. Sementara untuk layanan langganan, layanan tersebut akan kedaluwarsa setelah periode langganan saat ini berakhir dan tidak dapat diperpanjang secara otomatis.

Solusi:

1. Perbarui HMS Core (Huawei Mobile Services) ke versi terbaru. Jika aplikasi yang dimaksud tidak didistribusikan dalam kawasan layanan yang telah Anda tetapkan untuk klien HUAWEIAppGallery Anda, sistem akan menampilkan pesan yang menunjukkan kegagalan yang disebabkan ketika pembayaran Anda gagal.

2. Buka AppGallery > Saya > Pengaturan > Negara/kawasan, alihkan area layanan ke negara/kawasan tempat Anda mengunduh aplikasi yang dimaksud. Setelah itu, Anda akan dapat melakukan pembayaran dan mengaktifkan perpanjangan otomatis untuk aplikasi tersebut.

Berguna atau tidak?
Terimakasih atas masukan Anda.