Las aplicaciones de terceros se cierran inesperadamente, no abren o no responden

Producto aplicable: Smartphone
Producto aplicable:
Tips para la lista de conocimientos
Tips para errors
zoom in pic

Problema:

Algunas aplicaciones de terceros se cierran inesperadamente o no abren.


Causas:

  1. Tener demasiadas aplicaciones abiertas puede ocasionar la saturación de la memoria RAM dando como resultado el cierre inesperado de las mismas o que no puedan abrirse.
  2. No tener la versión de Android que la aplicación requiere.
  3. No tener la versión más actualizada de la aplicación.
  4. Existe un problema de compatibilidad entre la aplicación y el dispositivo.
  5. Hay problemas en el software del dispositivo.


Solución:

1. Se recomienda mantener ejecutando en segundo plano solo las aplicaciones indispensables para evitar el cierre inesperado de las mismas.

2. Reinicia la aplicación:

    1. Abre Ajustes
    2. Accede a Aplicaciones
    3. Elige Aplicaciones
    4. Localiza y acceder a la aplicación en cuestión
    5. Presiona Detener para salir de la aplicación
    6. Vuelve a abrir la aplicación

3. Es necesario corroborar que la aplicación es compatible con la versión del sistema operativo en el celular ya que si el sistema o la aplicación se encuentran desactualizados pueden ocasionar el cierre inesperado de aplicaciones. 

Si el dispositivo no cuenta con la versión de Android necesaria no se podrá ejecutar la aplicación.

En caso de que la aplicación esté desactualizada habrá que actualizarla a la última versión. Puedes hacerlo de alguna de las siguiente formas:
  • Accede a Huawei AppGallery o al sitio web oficial de la aplicación para actualizar la aplicación a la versión más reciente.
  • Busca actualizaciones en el dispositivo: 
        1. Abre Ajustes.
        2. Accede a Sistemas y actualizaciones.
        3. Elige Actualización de software.
        4. Presiona Buscar actualizaciones.
        5. Si hay una versión disponible, actualiza el teléfono a la versión más reciente.

4. Verifica los permisos de la aplicación: Es posible que una aplicación de terceros falle si no tiene algunos permisos.
  1. Abre Ajustes.
  2. Accede Aplicaciones.
  3. Ve a Aplicaciones.
  4. Elige la aplicación en cuestión.
  5. Accede a Permisos. 
  6. Otorga los permisos relacionados.

5. Libera espacio en el almacenamiento del teléfono. Si la memoria del sistema no es suficiente, es posible que algunas aplicaciones (como los juegos) que ocupan una gran cantidad de memoria se cierren inesperadamente. En este caso, se recomienda liberar un poco de espacio en la memoria para garantizar que haya, al menos, un 20% de memoria disponible. Realiza la siguiente:
  1. Accede a la pantalla de Tareas recientes.
  2. Presiona para cerrar las aplicaciones en segundo plano.
  3. Usa Optimizador para liberar espacio en el almacenamiento del dispositivo y desinstalar las aplicaciones que rara vez se utilizan.
  4. Reinicia el dispositivo para borrar la memoria caché. Se recomienda reiniciar el dispositivo cada 2 o 3 días para que funcione correctamente.

6. Realiza un restablecimiento de ajustes en caso de que sea viable.

7. Se sugiere desinstalar la aplicación, limpiar la memoria caché del teléfono y volver a instalar la aplicación.
Para conocer más sobre las diferentes opciones para limpiar la memoria caché, visita ¿Cómo borrar la memoria caché?

8. Realiza un restablecimiento a los valores de fábrica mediante los ajustes del teléfono:
  1. Abre Ajustes.
  2. Ve a Sistema y actualizaciones.
  3. Elige Restablecimiento.
  4. Toca Restablecer teléfono.
  5. Selecciona Restablecer y sigue las instrucciones en pantalla para terminar el proceso.

9. Si el problema persiste, acude con una copia de tu comprobante de compra a un centro de servicio de Huawei para recibir asistencia.
¿Es útil?
Gracias por tus comentarios.