El Wi-Fi se conecta y desconecta constantemente
Producto aplicable:
Tips para la lista de conocimientos
Tips para errors
Problema:
El Wi-Fi se desconecta frecuentemente y luego se vuelve a conectar automáticamente.
Causa:
1. Este problema puede ser causado por un problema con el roaming de Wi-Fi. Si hay varios hotspots móviles almacenados en el ordenador, éste se conectará automáticamente al hotspot Wi-Fi con la mejor señal. Si mueve el equipo con frecuencia a otras áreas, el equipo se conectará frecuente y automáticamente a otros puntos de acceso Wi-Fi.
El Wi-Fi se desconecta frecuentemente y luego se vuelve a conectar automáticamente.
Causa:
2. Este problema también puede ocurrir cuando hay dos puntos de acceso público (por ejemplo, uno es de 2,4 GHz y el otro de 5 GHz) con el mismo nombre de red y la misma contraseña. En este caso, el equipo se conectará automáticamente al punto de acceso Wi-Fi con la mejor señal y conexión de red.
3. Este problema puede ocurrir cuando el equipo envía un paquete de datos al enrutador y éste no responde. En este caso, el ordenador puede pensar que el router está apagado y luego se desconecta de él.
4. Este problema también puede ser causado por un controlador de Wi-Fi dañado.
Solución:

Si el problema sigue sin resolverse, haz una copia de seguridad de tus datos importantes, lleva tu ordenador, la prueba de compra y la tarjeta de garantía a un centro de atención al cliente autorizado de Huawei para recibir mayor asistencia.
3. Este problema puede ocurrir cuando el equipo envía un paquete de datos al enrutador y éste no responde. En este caso, el ordenador puede pensar que el router está apagado y luego se desconecta de él.
4. Este problema también puede ser causado por un controlador de Wi-Fi dañado.
Solución:
- Sólo guarda un punto de acceso en tu ordenador.
- Configura diferentes nombres para los puntos de acceso Wi-Fi de 2,4 y 5 GHz del router.
- Conecta el ordenador a otro punto de acceso y comprueba si se ha resuelto el problema.
- Si el problema persiste, puede deberse a un controlador de Wi-Fi defectuoso. Se recomienda reiniciar la red. Para ello, realiza lo siguiente: Haz clic en el icono de red de la barra de tareas y haz clic en Configuración de red e Internet > Estado > Restablecimiento de la red > Restablecer ahora.

Si este problema persiste, desinstala el controlador de Wi-Fi. Abre PC Manager y descarga la última versión del controlador.
Si el problema sigue sin resolverse, haz una copia de seguridad de tus datos importantes, lleva tu ordenador, la prueba de compra y la tarjeta de garantía a un centro de atención al cliente autorizado de Huawei para recibir mayor asistencia.
1. Para desinstalar el controlador Wi-Fi en la HUAWEI MateBook X, la HUAWEI MateBook E, y la HUAWEI MateBook D, abre el Administrador de Dispositivos, expande los adaptadores de red, haz clic con el botón derecho del ratón en Intel(R) Wireless-AC XXXX, y haz clic en Desinstalar dispositivo.
2. Para desinstalar el controlador Wi-Fi en el HUAWEI MateBook X Pro, el HONOR MagicBook y el HONOR MagicBook (Ryzen), realiza lo siguiente:
a. Abre el Panel de Control, haz clic en Programas > Desinstalar un programa. Haz doble clic en Intel®PROSet/Wireless Software para eliminar el programa.b. Abre el Administrador de dispositivos y ampliar los componentes de software, haz clic con el botón derecho del ratón en Intel®PROSet/Wireless Software y haz clic en Desinstalar dispositivo.c. Abre el Administrador de dispositivos y ampliar los adaptadores de red, haz clic con el botón secundario en Intel(R) Wireless-AC 8265 y haz clic en Desinstalar dispositivo.
3. Para desinstalar el controlador de Wi-Fi en el HUAWEI MateBook 13, abre el Administrador de dispositivos y amplíe los adaptadores de red, haz clic con el botón derecho del ratón en Intel(R) Wireless-AC 9560 y haz clic en Desinstalar dispositivo.
Gracias por tus comentarios.