The call screen on my HUAWEI watch disappears, or the watch displays the message "There might be too many Bluetooth devices connected. Disconnect some to answer the call."

Applicable products: HUAWEI WATCH FIT 4,HUAWEI WATCH GT 5 Pro,HUAWEI WATCH FIT 3,HUAWEI WATCH Ultimate 2(green),Honma x HUAWEI Watch GT6 Pro,HUAWEI WATCH GT 3 SE,HUAWEI WATCH | ULTIMATE DESIGN,HUAWEI WATCH | ULTIMATE DESIGN Royal Gold,HUAWEI WATCH GT 3 Pro,HUAWEI WATCH GT Runner 2,HUAWEI WATCH Ultimate,HUAWEI WATCH GT Runner,HUAWEI WATCH GT 2(46mm sport(latona-b19p)、46mm classic、46mm sport(latona-b19s)、46mm elite),HUAWEI WATCH Ultimate 2,HUAWEI WATCH GT Cyber,HUAWEI WATCH FIT 4 Pro,HUAWEI WATCH GT 6,HUAWEI WATCH GT 2 Pro,HUAWEI WATCH 5,HUAWEI WATCH GT 5,HUAWEI WATCH D2,HUAWEI WATCH GT 6 Pro,HUAWEI WATCH GT 4,HUAWEI WATCH GT 3
Applicable products:
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The call screen on my HUAWEI watch disappears, or the watch displays the message "There might be too many Bluetooth devices connected. Disconnect some to answer the call."

Problem

Smart watches: HUAWEI WATCH Series and HUAWEI WATCH Ultimate 2 Series

Sports watches: HUAWEI WATCH GT Series, HUAWEI WATCH FIT Series, and HUAWEI WATCH D/D2

Device

System Mode

Problem

Legend

Smart watches

Standard mode

  1. The call screen on my watch disappears 3 seconds after there is an incoming call on my phone.
  2. The dialer screen disappears 3 seconds after the watch makes an outgoing call.

Power Saving mode

When there is an incoming call on the phone or an outgoing call on the watch, the watch displays the message "There might be too many Bluetooth devices connected. Disconnect some to answer the call."

Sports watches

N/A

Cause

  1. The number of Bluetooth devices that can be connected to each phone at the same time varies. If too many Bluetooth devices are connected to your phone or other exceptions occur, the call audio channel between your watch and phone will fail to be set up.
  2. The Phone calls switch in the watch pairing information in the Bluetooth settings on your phone has been turned off . As a result, the call audio channel between the watch and phone fails to be set up when there is an incoming or outgoing call.

Solution

  • Check whether your phone is connected to multiple Bluetooth devices by going to Settings > Bluetooth on your phone. If so, disconnect your phone from other Bluetooth devices or remove connections, and try again.
  • Go to Settings > Bluetooth on your phone and enable Phone calls in the watch pairing information.

    When the watch is properly connected to Huawei Health, you may have manually turned on Phone calls but it is then automatically turned off. As this will be automatically enabled when you receive an incoming call from the phone or make an outgoing call from the watch, please rest assured.

  • If the issue persists, restore your phone's network settings, and pair your phone and watch again. The following uses a HUAWEI phone as an example:

    This operation will restore the settings of the WLAN, mobile data network, Bluetooth, and NearLink that your phone has connected to. Other data will not be deleted and other settings will not be modified.

    Phone's System Version

    Operation Path

    HUAWEI phones running EMUI 9.0 or later

    Go to Settings > System & updates > Reset > Reset network settings.

If the issue persists

If the issue persists or you encounter any difficulties, please call the Huawei customer service hotline for assistance. We will do our best to address your needs.

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