My HUAWEI wearable device displays a message indicating that the phone is connecting to too many Bluetooth devices and a call can be made after disconnecting some devices
| My HUAWEI wearable device displays a message indicating that the phone is connecting to too many Bluetooth devices and a call can be made after disconnecting some devices |
Problem
When a call comes in, the watch displays a message indicating that the phone is connecting to too many Bluetooth devices and a call can be made after disconnecting some devices.
Cause
The Bluetooth devices that can be connected to a phone at the same time vary depending on the phone model. If a phone is connected to too many Bluetooth devices or other exceptions occur, the call audio channel between the watch and phone will fail to be set up.
Solution
- Go to Settings > Bluetooth on your phone, disable Bluetooth, and re-enable Bluetooth to try again.
- Check whether your phone is connected to multiple Bluetooth devices by going to Settings > Bluetooth. If so, disconnect your phone from other Bluetooth devices and try again.
- Restore your phone's network settings and reconnect your phone and watch. To restore the network settings, perform the following steps:
1. Non-HarmonyOS 5 systems: Go to Settings > System & updates > Reset > Reset network settings.
If the issue persists or you encounter any difficulties, please call the Huawei customer service hotline for assistance. We will do our best to address your needs.